Results 1 to 4 of 4

ignition problems

This is a discussion on ignition problems within the General Help forums, part of the LSx Technical Help Section category; I have 00 camaro ss with 166k miles on it about 30k miles ago my engine popped one of the ...

  1. #1
    Junior Member
    Join Date
    Oct 2007
    Location
    florida
    Posts
    15

    red
    2000 camaro ss

    car just blew a spark plug off the passenger head

    I have 00 camaro ss with 166k miles on it about 30k miles ago my engine popped one of the spark plugs right off. When I checked it out i found the thread on the engine was no good so i re-thread it and put a new spark plug in . now it happened again but on a different spark plug, has anyone heard of this before? and do you have any suggestions?
    Last edited by bulljock; 01-06-2009 at 05:40 PM.

  2. #2
    That guy thearborbarber's Avatar
    Join Date
    Nov 2007
    Location
    SoDak
    Posts
    892

    White over Red
    1991 Suburban

    I have heard of it mostly on ford 5.4l trucks.

  3. #3
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    It does happen occasionally with aluminum heads. After several plug changes especially without anitseize the threads can pull out. Is it just doing it on one side of the engine? When was the last time the plugs were changed?

  4. #4
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Pick up a set of stock heads to replace them. You can only thread these heads so many times, Helicoil may work. Did you over torque the plugs? Right plugs?
    J
    2001 SS, Its not the car its the Driver that matters....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Steering column, ignition problems
    By Lunatikgixxer in forum Firebird / WS6
    Replies: 38
    Last Post: 01-14-2011, 05:40 AM
  2. Ignition Problems 2
    By 00A4SS in forum External Engine
    Replies: 0
    Last Post: 06-10-2007, 10:24 AM
  3. Ignition Problems
    By 00A4SS in forum External Engine
    Replies: 5
    Last Post: 05-24-2007, 04:49 PM
  4. Ignition Problems
    By justgot98 in forum General Help
    Replies: 3
    Last Post: 09-07-2006, 11:11 AM
  5. removal of cats and ignition problems
    By knewsock in forum External Engine
    Replies: 5
    Last Post: 04-21-2006, 09:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •