Results 1 to 6 of 6

Ignition Problem/ Concern ??? Help

This is a discussion on Ignition Problem/ Concern ??? Help within the General Help forums, part of the LSx Technical Help Section category; Here is my problem and concern...When i fire up my SS I feel like it struggles just a bit what ...

  1. #1
    Junior Member 01JameSS's Avatar
    Join Date
    Aug 2005
    Location
    Los AngeleSS
    Age
    34
    Posts
    96

    Light Pewter Metalic
    01 Camaro SS

    Question Ignition Problem/ Concern ??? Help

    Here is my problem and concern...When i fire up my SS I feel like it struggles just a bit what can it be? an alternator problem, starter, wires ???? it does turn on but, it seems like it doesnt turn on the same way it used to...

  2. #2
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    how many miles? might be time for a plug change.

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Mine wasn't firing up like usual last week, especially when cold - had battery load tested and it was bad, even though it showed good voltage on my DVM.

  4. #4
    Tech Junkie hammertime's Avatar
    Join Date
    Nov 2005
    Location
    Belleville, IL
    Posts
    400

    Pewter Metallic
    2001 Camaro SS

    Quote Originally Posted by 2001NBMZ28
    Mine wasn't firing up like usual last week, especially when cold - had battery load tested and it was bad, even though it showed good voltage on my DVM.
    I would start here, as changing the battery is far easier then changing the plugs. What is your mileage? Daily driver?

    My car sits a lot, so I'm expecting this to be my last year on the battery.
    Hammer - hammertime.us
    2001 Light Pewter Metallic Camaro SS, 6 speed
    K&N, SLP Lid, SLP y-pipe, GMMG cat-back, Lou's Short Stick - more to come!

  5. #5
    Junior Member 01JameSS's Avatar
    Join Date
    Aug 2005
    Location
    Los AngeleSS
    Age
    34
    Posts
    96

    Light Pewter Metalic
    01 Camaro SS

    thanks to all....It was the battery...works like a champ again...

  6. #6
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Glad it was something easy. I'm on my third battery now at 23K (lots of short daily trips). OEM Delco completely died just after 3 year warranty expired, Diehard Gold I replaced it with just quit - Sears gave me full credit on the old one so I traded it for an Optima Red Top this time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ignition Struggle
    By 01JameSS in forum Camaro / SS
    Replies: 2
    Last Post: 01-02-2006, 10:06 PM
  2. Problem after Problem
    By boone94 in forum Internal Engine
    Replies: 9
    Last Post: 11-04-2005, 06:31 PM
  3. 98 Z28: does this sound like an ignition switch problem?
    By Motrv8d Steve in forum General Help
    Replies: 12
    Last Post: 11-02-2005, 08:33 AM
  4. SERIOUS Tranny Problem! HELP!!!
    By GTObsessor in forum Manual Transmission
    Replies: 7
    Last Post: 10-25-2005, 06:19 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •