Results 1 to 19 of 19

Idle Problem please help

This is a discussion on Idle Problem please help within the General Help forums, part of the LSx Technical Help Section category; i have a 2000 camaro z28, today i was pulling onto the road, gave it a little gas, car took ...

  1. #1
    Junior Member
    Join Date
    Jun 2008
    Location
    Florida
    Posts
    10

    Black
    2000 Camaro Z28

    Idle Problem please help

    i have a 2000 camaro z28, today i was pulling onto the road, gave it a little gas, car took off, then started sputtering, then engine died, i coasted off the road, car didn't want to start, finally got it started, i have to hold the gas about half way down to keep it idled, and running, once i let off the gas the car dies.... Any ideas ?? Please help this is my DD

  2. #2
    I have a need for speed! jigger1166's Avatar
    Join Date
    Dec 2006
    Location
    Standish,Maine
    Age
    51
    Posts
    560

    Artic White
    00 SS Vert.

    Was something done under the hood recently?
    Are there any DTCs?

  3. #3
    Junior Member
    Join Date
    Jun 2008
    Location
    Florida
    Posts
    10

    Black
    2000 Camaro Z28

    nothing has been done under the hood, or anywhere on the car as far as maintenance is concerned. Also, i couldn't find any fluid leaking anywhere.

    Haven't been able to check codes yet

  4. #4
    Yo Da Lin The Valley..... astyles's Avatar
    Join Date
    Mar 2006
    Location
    here
    Posts
    3,693
    2001

    fuel pump........mine did the same thing

  5. #5
    Junior Member
    Join Date
    Jun 2008
    Location
    Florida
    Posts
    10

    Black
    2000 Camaro Z28

    if it is the fuel pump will that show as a code ?

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    is your check engine light on? If it is I would get those codes first and that'll help out a bunch. You can always check your fuel pressure if you suspect the pump....the valve is on the end of the drivers side rail and pressure should be ~58psi. Replace the fuel filter first if the pressure is low.

  7. #7
    Junior Member
    Join Date
    Jun 2008
    Location
    Florida
    Posts
    10

    Black
    2000 Camaro Z28

    replaced fuel filter a couple months ago, check engine light is on, going to check if i bent a push rod or messed up a valve also in the morning

  8. #8
    Alien Baby FuriousGeorge's Avatar
    Join Date
    Feb 2006
    Location
    Tinker AFB, Oklahoma
    Age
    32
    Posts
    185

    Midnight Blue
    2000 Camaro Z28

    could be your fuel pressure regulator. just pull the vacuum line off of it and see if gas comes out. if it does, it's bad. if you don't see any, try to get it running and pull it off...then keep watching for gas. only reason i bring it up is it's really easy to check for and it gets overlooked often.

  9. #9
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Quote Originally Posted by FuriousGeorge View Post
    could be your fuel pressure regulator. just pull the vacuum line off of it and see if gas comes out. if it does, it's bad. if you don't see any, try to get it running and pull it off...then keep watching for gas. only reason i bring it up is it's really easy to check for and it gets overlooked often.
    fpr is part of the fuel pump module and is in the tank.

  10. #10
    Alien Baby FuriousGeorge's Avatar
    Join Date
    Feb 2006
    Location
    Tinker AFB, Oklahoma
    Age
    32
    Posts
    185

    Midnight Blue
    2000 Camaro Z28

    yeah nevermind, i'm an idiot...just realized that. i've been working on way too many other cars lately. i am hanging my head in shame right now.

  11. #11
    Junior Member
    Join Date
    Jun 2008
    Location
    Florida
    Posts
    10

    Black
    2000 Camaro Z28

    Pulled the valve cover, found a valve retainer or "keeper" came off #4 , pushrods look fine, rocker's look fine.

    Just ordered the keepers 0.19 cent part is holding me down

  12. #12
    Junior Member
    Join Date
    Jun 2008
    Location
    Florida
    Posts
    10

    Black
    2000 Camaro Z28

    Got a bent valve, got to pull head

  13. #13

  14. #14
    Junior Member
    Join Date
    Jun 2008
    Location
    Florida
    Posts
    10

    Black
    2000 Camaro Z28

    Pulled the head, had a bent valve, replaced the valve, also had a bad lifter. All is good !!!! Before, the car had a knock to the engine... and it's GONE... Sounds beautiful

  15. #15
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    glad you got it fixed...... I would play the lottery because if you lost a keeper and didn't destroy the engine you're very lucky

  16. #16
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by 0rion View Post
    glad you got it fixed...... I would play the lottery because if you lost a keeper and didn't destroy the engine you're very lucky
    NS!!!!! You are a lucky man.

  17. #17
    Junior Member
    Join Date
    Jun 2008
    Location
    Florida
    Posts
    10

    Black
    2000 Camaro Z28

    I feel very lucky, i was worried what the piston was going to look like, but it looked fine. The "cup" on the lifter was lower than normal, i think some previously put a lifter for a V6 camaro on it, it was a major difference between the other lifters. I'm obviously happy it's running, but you have no idea how glad i was that there is absolutely no knocking from the engine.

  18. #18
    Junior Member
    Join Date
    Jun 2008
    Location
    Florida
    Posts
    10

    Black
    2000 Camaro Z28

    Thanks to everyone for their help, i appreciate it

  19. #19
    Member
    Join Date
    Oct 2005
    Location
    San Antonio
    Age
    46
    Posts
    289

    Silver & Black
    99 Camaro SS

    I'm glad you posted...it is nice to hear a story of calamity and collateral damage avoided.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Idle Problem!!!
    By 00hawk109 in forum General Help
    Replies: 7
    Last Post: 10-11-2011, 02:38 PM
  2. 01 S-10 4.3l idle problem
    By TwinTA in forum GM Trucks
    Replies: 5
    Last Post: 03-28-2009, 03:17 PM
  3. Question: different idle problem
    By Brad(WS/Z0.6) in forum General Help
    Replies: 16
    Last Post: 01-31-2009, 08:19 AM
  4. Idle Problem
    By larryndog in forum V6
    Replies: 2
    Last Post: 08-13-2006, 05:55 PM
  5. idle problem
    By occamaroz in forum General Help
    Replies: 4
    Last Post: 06-17-2006, 10:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •