Results 1 to 6 of 6

I think i broke pcv line??

This is a discussion on I think i broke pcv line?? within the General Help forums, part of the LSx Technical Help Section category; I am in the middle of doing my heads/cam/headers/nitrous install and was takin apart everything and was reading the write ...

  1. #1
    Member
    Join Date
    Jun 2008
    Location
    ohio
    Posts
    393

    black
    1998 Camaro SS

    I think i broke pcv line??

    I am in the middle of doing my heads/cam/headers/nitrous install and was takin apart everything and was reading the write you guys gave me for heads/cam install. it told me to pull on the pcv the goes to the front of intake. well i didnt pull on it with much force and it "broke" off in the middle of line. The weird thing is that where it broke it looks like around the line is styrofoam (spelling?) and there was tape all around the part that broke like it had been broken before and just taped back up. Was that part supposed to be like that or was it broke before and whoever had the car last tape it back up? Any info?

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    the pcv valve is in there. Might've just pulled it out of the valve. Even if it's broke you can get some hose and make your own. Just keep going.

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    did you get center bolt valve covers? Unless you got them from a 99 you're going to have to re-do your pcv system anyhow as most of the center bolt covers don't have the port on the rear of the passenger side. I ended up swapping with someone on here that had a 99 and was swapping to perimeter covers. here's the link when I was doing mine.
    98 pcv question

  4. #4
    Member
    Join Date
    Jun 2008
    Location
    ohio
    Posts
    393

    black
    1998 Camaro SS

    Thanks for the info. ok well that was good news and bad news lol. i have this huge install and worried i wont get it done in time when it finally gets warm here in ohio. Thanks for the help th orion.

  5. #5
    Member
    Join Date
    Jun 2008
    Location
    ohio
    Posts
    393

    black
    1998 Camaro SS

    Attachment 18254

    Ok so these are like the valve covers i have, mine arent as nice as these but whatever. So these won't work with the pcv thats on the car now? What does it need to have? that hole in the back like the drivers side cover has? Anyone know where i can get a pair that will work?

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    you can make those work....you'll just have to re-plumb the pcv. When I had those covers I was looking at a couple different options to make them work. You could T the port on the rear drivers with the front port on the passengers side and then have the pcv valve between that and the intake.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: vacuum line broke when doing wire hide mod
    By godless-phoenix in forum General Help
    Replies: 9
    Last Post: 03-12-2012, 08:17 AM
  2. Brake booster line broke
    By Lunatikgixxer in forum General Help
    Replies: 4
    Last Post: 11-14-2011, 07:53 PM
  3. i broke it!
    By DCC!! in forum External Engine
    Replies: 14
    Last Post: 09-14-2009, 09:54 AM
  4. Line lock/ brake line ?
    By 2001z in forum Suspension and Handling
    Replies: 3
    Last Post: 04-01-2007, 06:42 AM
  5. Please try and tell me what I broke
    By RideZX-6R in forum Manual Transmission
    Replies: 3
    Last Post: 02-01-2006, 11:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •