Results 1 to 18 of 18

I smell gas

This is a discussion on I smell gas within the General Help forums, part of the LSx Technical Help Section category; when i drive my 94 trans am i smell gas fumes comming from the back of the car. pritty strong ...

  1. #1
    Junior Member northslider's Avatar
    Join Date
    Dec 2009
    Location
    Navarre FL
    Posts
    48

    black, white
    99 firehawk 94 25th anni

    I smell gas

    when i drive my 94 trans am i smell gas fumes comming from the back of the car. pritty strong too. any ideas. all the hoses from the tank are connected.

  2. #2
    Member Adam_94_T/A's Avatar
    Join Date
    Oct 2009
    Location
    North Carolina
    Posts
    112

    White
    1994 Pontiac T/A

    i also have a 94 t/A AND MINE DOES THE SAME IDK what the heck it is either lol

  3. #3
    LSwut tep98ws6's Avatar
    Join Date
    Jun 2009
    Location
    Saint Louis, MO
    Posts
    1,705

    Arctic White & Black
    '98 WS6 M6 - SWAPTIME!

    ... is your gas cap on all the way? mine clicked a few times after i filled up one time and i smelled gas in a major way but it was on crooked. double check the cap.

    if not, make sure your fuel rail is all the way down and all the injectors are snapped fully into place

  4. #4
    Member Adam_94_T/A's Avatar
    Join Date
    Oct 2009
    Location
    North Carolina
    Posts
    112

    White
    1994 Pontiac T/A

    i replaced my gas cap also and it still smells old one would leak on full tank

  5. #5
    LSwut tep98ws6's Avatar
    Join Date
    Jun 2009
    Location
    Saint Louis, MO
    Posts
    1,705

    Arctic White & Black
    '98 WS6 M6 - SWAPTIME!

    is your tank or filler neck cracked?

  6. #6
    Member Adam_94_T/A's Avatar
    Join Date
    Oct 2009
    Location
    North Carolina
    Posts
    112

    White
    1994 Pontiac T/A

    nope everything checks out good just smell of gas fumes when i get in the car in the mornings its okay for me tho would like to know why but the hint of fuel does add a nice touch to waking up in the morning lol only if i could figure out how to get a burnt tire smell then we'll be golden

  7. #7
    LSwut tep98ws6's Avatar
    Join Date
    Jun 2009
    Location
    Saint Louis, MO
    Posts
    1,705

    Arctic White & Black
    '98 WS6 M6 - SWAPTIME!

    hahah well okay then.
    have you recently changed the fuel filter? have you ever checked your fuel pressure? at the rail, regulator and pump? maybe you have a bad regulator or pump.

    just throwing out ideas. mine used to smell like gas all the time and i needed a new regulator and pump. then that one time was just the cap

  8. #8
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    what about all the evap lines? One may have a leak. It should throw a code for that though. Have you had any evap codes?

  9. #9
    Member Adam_94_T/A's Avatar
    Join Date
    Oct 2009
    Location
    North Carolina
    Posts
    112

    White
    1994 Pontiac T/A

    nope never check fuel pressure to see if pump is bad which would suck o well will check it you have any idea of what the pressure for the lt1 with its pump should be ?

  10. #10
    LSwut tep98ws6's Avatar
    Join Date
    Jun 2009
    Location
    Saint Louis, MO
    Posts
    1,705

    Arctic White & Black
    '98 WS6 M6 - SWAPTIME!

    Quote Originally Posted by Adam_94_T/A View Post
    nope never check fuel pressure to see if pump is bad which would suck o well will check it you have any idea of what the pressure for the lt1 with its pump should be ?
    from what i've found so far - ignition on/engine off should be 41-47PSI

  11. #11
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by northslider View Post
    when i drive my 94 trans am i smell gas fumes comming from the back of the car. pritty strong too. any ideas. all the hoses from the tank are connected.
    wasn't me...

    you might be running rich also...

  12. #12
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Wow. Adam thread jacked the shit out of this thread

    I was going to say what Spaz mentioned, running rich.

    To the OP - any SES light?

  13. #13
    LSwut tep98ws6's Avatar
    Join Date
    Jun 2009
    Location
    Saint Louis, MO
    Posts
    1,705

    Arctic White & Black
    '98 WS6 M6 - SWAPTIME!

    Quote Originally Posted by 35th-ANV-SS View Post
    Wow. Adam thread jacked the shit out of this thread

    I was going to say what Spaz mentioned, running rich.

    To the OP - any SES light?

  14. #14
    Member Adam_94_T/A's Avatar
    Join Date
    Oct 2009
    Location
    North Carolina
    Posts
    112

    White
    1994 Pontiac T/A

    well we both seem to have the same problem and same year car so kinda ironic lol sorry to the OP maybe with me chatting away he has a few leads to start with lol

  15. #15
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Maybe someone made a fuel pump access cutout under the trunk carpet?

  16. #16
    Junior Member northslider's Avatar
    Join Date
    Dec 2009
    Location
    Navarre FL
    Posts
    48

    black, white
    99 firehawk 94 25th anni

    first off i dont mine the jacking if the problem get solved i found a loose evap line to the canaster behind the rear drivers wheel. thought "awsome problem solved" but no still gas in the car. maybe the check valve back there is blocked

  17. #17
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    Quote Originally Posted by northslider View Post
    first off i dont mine the jacking if the problem get solved i found a loose evap line to the canaster behind the rear drivers wheel. thought "awsome problem solved" but no still gas in the car. maybe the check valve back there is blocked
    hmmm... have you scanned for any codes??? even though the SES light isn't on there still might be codes in there...

  18. #18
    Junior Member northslider's Avatar
    Join Date
    Dec 2009
    Location
    Navarre FL
    Posts
    48

    black, white
    99 firehawk 94 25th anni

    should....will this weekend

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. i smell gas
    By damianj03 in forum External Engine
    Replies: 13
    Last Post: 04-03-2010, 02:57 AM
  2. gas smell !
    By tdeath in forum GTO
    Replies: 11
    Last Post: 06-25-2007, 08:12 AM
  3. New Car Smell!
    By Ryanater in forum Showcar and Detailing
    Replies: 17
    Last Post: 04-24-2007, 06:26 PM
  4. gas smell
    By 94redmaro in forum General Help
    Replies: 5
    Last Post: 01-17-2007, 06:17 AM
  5. Car Smell !!!
    By Solidify in forum Firebird / WS6
    Replies: 5
    Last Post: 10-30-2006, 11:31 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •