Page 2 of 2 FirstFirst 12
Results 21 to 25 of 25

i really need help. camaro is pissing me off

This is a discussion on i really need help. camaro is pissing me off within the General Help forums, part of the LSx Technical Help Section category; Well just got the Camaro back..... It was the fans .... Reflushed the system...... I am so happy.. Thanks guys...

  1. #21
    Member cancam99ss's Avatar
    Join Date
    Apr 2010
    Location
    Miami
    Posts
    540

    Navy Blue
    Chevrolet Camaro SS

    Well just got the Camaro back..... It was the fans .... Reflushed the system...... I am so happy.. Thanks guys

  2. #22
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    I don't understand how it could have been the fans when they came on when you turned your AC on...

  3. #23
    Member cancam99ss's Avatar
    Join Date
    Apr 2010
    Location
    Miami
    Posts
    540

    Navy Blue
    Chevrolet Camaro SS

    Well apparently the ac fan is the second speed.. The car was overheating when stopped only.... When on the high way didn't happen... So the mechanic dis the following tested the motors the low the one that first goes on was not working.... He got brand new ls1 fans and flushed the system again and today I drove the shit out of it and nothing happened..... So I'm glad it wasn't a head gasket

  4. #24
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Well then enjoy.

  5. #25
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,997

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by cancam99ss View Post
    Well apparently the ac fan is the second speed.. The car was overheating when stopped only.... When on the high way didn't happen... So the mechanic dis the following tested the motors the low the one that first goes on was not working.... He got brand new ls1 fans and flushed the system again and today I drove the shit out of it and nothing happened..... So I'm glad it wasn't a head gasket
    Yep, that makes sense. The fans are wired in series for low speed, so if one bad, either one will come on for low speed.
    In high speed (and AC mode), each fan is supplied its own power and ground, so one should have worked and the bad one wouldn't.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wife is pissing me off.
    By Spikito in forum Almost Anything Goes
    Replies: 59
    Last Post: 04-04-2012, 06:45 AM
  2. My car is pissing on itself
    By SMWS6TA in forum General Help
    Replies: 6
    Last Post: 03-01-2012, 06:22 PM
  3. Cars pissing me off
    By Spikito in forum Camaro / SS
    Replies: 16
    Last Post: 03-23-2011, 12:49 PM
  4. He's pissing everyone off
    By GTP231 in forum Political / Debate Forum
    Replies: 0
    Last Post: 03-10-2010, 08:01 PM
  5. Civic pissing me off
    By GottaHaveLS1 in forum Kill Stories
    Replies: 2
    Last Post: 07-09-2006, 09:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •