Results 1 to 10 of 10

I made a boo boo, need help

This is a discussion on I made a boo boo, need help within the General Help forums, part of the LSx Technical Help Section category; Ok recently I purchased white gauge face overlays and LEDs. To install them it was much easier to remove the ...

  1. #1
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    I made a boo boo, need help

    Ok recently I purchased white gauge face overlays and LEDs.
    To install them it was much easier to remove the cluster and removed the needles as well.
    Well I did this last night but didnt notice till today that my speedometer is off.
    Also when I turn off the car the needle goes ALL the way down. I think the RPM might be a little off now too casue it suddenly idles at like 12-1300. Normally it should be at 1000.
    I am thinking if I took out the cluster again I should move both the RPM and speedometer needles right at the 0 mark. Would this fix it or do I need to do something else?
    BTW my car is a 96 Z28 M6 if it makes a difference.
    Thanks in advance.

  2. #2
    your parts guy!!! 1fastcamarosss11's Avatar
    Join Date
    Aug 2005
    Location
    cleveland ohio
    Posts
    11,376

    trans am 00 ws6
    1998 camaro ss vert

    you get the needles back on the right ones?

  3. #3
    Member nillam1's Avatar
    Join Date
    Apr 2009
    Location
    Toronto, Ontario, Canada.
    Posts
    392

    Red
    2002 Camaro Z28

    Thumbs up

    You might need to buy a new (used) cluster.
    2002 Camaro Z28 Bolt ons, Flowmaster catback w/3" QTP electric cutout, Superchips tuned, Granatelli MAF, SLP cold air induction Lid & filter, ZEX powertune plugs, Taylor 10.4mm wires, 160 T-stat w/fan control, Eibach sportlines & BFG-KDW's on 17" SLP SS rims.

  4. #4
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    My 01 Camaro's speedo needle rests on the column hump in the cluster from factory. Not sure I bet yours did too. Maybe you did'nt notice that on yours and when you replaced the needle you set it @ the wrong position? You can remove the needles again reinstall the dash cluster and turn the ignition on then off with out starting it up. Then replace needles again and see if that changes it any. Because powering up the dash and turning it off may reset everything back to the right spots. I had a 95 Camaro but cant remember if it rested on the hump. I'd just try powering it up and then down again as I said earlier.
    Last edited by Smittro; 09-14-2009 at 10:13 PM.

  5. #5
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Quote Originally Posted by Smittro View Post
    My 01 Camaro's speedo needle rests on the column hump in the cluster from factory. Not sure I bet yours did too. Maybe you did'nt notice that on yours and when you replaced the needle you set it @ the wrong position? You can remove the needles again reinstall the dash cluster and turn the ignition on then off with out starting it up. Then replace needles again and see if that changes it any. Because powering up the dash and turning it off may reset everything back to the right spots. I had a 95 Camaro but cant remember if it rested on the hump. I'd just try powering it up and then down again as I said earlier.
    I didn't pay attention to where I set it at when I put the needles back. Im guessing that I probably did set it to the wrong position thinkinging that the computer would automaticlly move to the right place. I guess I am going to take it out again and set it to the right resting point when its off, I hope it works.

  6. #6
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    you could set the needles to zero with the cluster plugged in and the key on.

  7. #7
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Quote Originally Posted by Cutlass View Post
    you could set the needles to zero with the cluster plugged in and the key on.
    Well I still need to remove parts of the dash around it to remove the glass piece. I just never have any time.

  8. #8
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Quote Originally Posted by JwMonE99 View Post
    Well I still need to remove parts of the dash around it to remove the glass piece. I just never have any time.
    Sounds like a weekend project to me.

  9. #9
    Rice Killa JwMonE99's Avatar
    Join Date
    Aug 2006
    Location
    Myrtle Beach
    Age
    27
    Posts
    5,561

    Black With T-Tops
    96 Z28 M6

    Quote Originally Posted by cammed goat View Post
    Sounds like a weekend project to me.
    With my luck its going to take a month till I can do it.

  10. #10
    Member 6.0LiterImportEater's Avatar
    Join Date
    Feb 2009
    Location
    Frederick, MD
    Posts
    187

    Phantom Black Metallic
    2006 Pontiac GTO

    Its just the wrong position.....trust me.

    I did a complete LED swap on a tach with white gauge overlays and this happened to me but worse. My rpm at idle was at 3500 haha!

    I just had to fiddle with it until I got it back to working right again. Not a big deal just time consuming.

    Good luck!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Made in The World labels, Made in USA not allowed.
    By KahanaReef in forum Political / Debate Forum
    Replies: 4
    Last Post: 06-12-2012, 11:20 AM
  2. Another vid I just made
    By JD_Z28 in forum Western Members
    Replies: 14
    Last Post: 08-13-2009, 01:03 PM
  3. I made it!
    By ArizonaLS1 in forum New Member Introductions
    Replies: 7
    Last Post: 04-15-2009, 03:43 AM
  4. What made you want it?
    By clg82 in forum Firebird / WS6
    Replies: 27
    Last Post: 09-07-2007, 12:18 PM
  5. LOL! I just made myself cry!
    By anti-social in forum Multimedia Section
    Replies: 1
    Last Post: 10-16-2006, 10:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •