Results 1 to 6 of 6

I have no idea...

This is a discussion on I have no idea... within the General Help forums, part of the LSx Technical Help Section category; Just installed LTs w/ ory... It's been about 2 weeks since the install and the car has always ran like ...

  1. #1
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    I have no idea...

    Just installed LTs w/ ory... It's been about 2 weeks since the install and the car has always ran like a top. But Wed. at one point when I was sitting in traffic, I noticed the car was ideling ROUGH... and when I went to step on the gas it acted like it was going to cut out. I had to feather the clutch just to keep it running.

    The car normaly idles between 790-820, Ive noticed sometimes when this problem is going on it dips as low at 550. It doesnt always idle low when it happens, It did it quite a bit yesterday, mainly when them temp. is within the first quarter marks on the guage.

    I know you should get the car tuned when you delete cats, and remove EGR, is this basicaly whats going on? Couple of friends who rode with me thought they felt it was running rich?

  2. #2
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    Getting it tuned should clear it up.

    How are the plugs and wires?
    1999 Camaro SS/ Pewter/ #1775 - LS1 6-speed - Predator 3 Custom Tune - Pro 5.0 - LS7 Clutch - 3.90's - Koni's - Strano Springs and Sway Bars - SFC's - Full UMI Chassis and Suspension - LS6 Intake PnP TB - ARH LT's and Kitty Ran Away - Magnaflow.

    12.6 at 112

    http://www.fquick.com/Tyler_LS1

  3. #3
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    plugs are brand new... Well, I say brand new but i installed new ones after i put a bottle in the trunk. They *MIGHT* have 7,000 miles on them. Wires are stock but they appear to be in solid condition.

  4. #4
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    No matter what you will want to get it tuned, ive got LT's, ORY and stock tune and i get horrible gas mileage, its stumbles once in a great while but its getting a tune real soon.

  5. #5
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    The car has aleady had a professional tune, shouldn't be an issue getting a "touch up".

  6. #6
    Member edbird's Avatar
    Join Date
    Apr 2006
    Location
    hammond Ind
    Posts
    270

    red
    1999 trans am convert

    If anyone has a comnplaint after LT's and ORYs,it's always "rough idle or bad MPG".IMHO if it ran good before it should also run good after-mine did.If it ran good after and starts running like crap, I'm thinking something came loose.I haven't got a tune yet and it runs magnificent-I could not be happier.But I will get a tune some day,for sure.
    If it ran like crap as soon as your done, I would suspect something not hooked up right.
    As for gas mileage,there is no way in hell to tell if LT+ORY had any effect at all on MPG without filling up,getting on the highway for 100-150 miles and getting off ,fill up again and check mileage-end of story,thats it!No one, and I mean NO ONE, drives their new modded car the same around town with new LT's+ORY than before!!!We all got our foot in it worse than ever,enjoying the new sound and power so MPG goes to HELL!!!
    I knew my highway mileage before mods and always check after.Good news is,I picked up about 1.5MPG with the LT+ORY and am very happy with that BUT,damnit,I can't keep my foot off it around town LOL! So i guess my mileage went down! But if I go on a trip,I'm Gold!
    This is all my opinion, I'm not a tuner. This is just my experiance with LT's+ORY.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. good idea? bad idea?
    By third_shift|studios in forum Multimedia Section
    Replies: 7
    Last Post: 05-31-2007, 11:25 AM
  2. Good Idea? bad idea? zboner's trade off
    By third_shift|studios in forum Almost Anything Goes
    Replies: 54
    Last Post: 11-28-2006, 12:19 AM
  3. bad idea or good idea?
    By FrienldyLS1 in forum External Engine
    Replies: 4
    Last Post: 11-13-2006, 10:42 AM
  4. Good Idea/Bad Idea..? be gentle
    By EREBUSS in forum General Help
    Replies: 7
    Last Post: 09-14-2006, 03:45 AM
  5. good idea? bad idea? Fiance's Bday gift...
    By third_shift|studios in forum Almost Anything Goes
    Replies: 25
    Last Post: 08-23-2006, 06:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •