Results 1 to 5 of 5

and i was excited for warm weather =/

This is a discussion on and i was excited for warm weather =/ within the General Help forums, part of the LSx Technical Help Section category; drove my 96 lt1 today and after 15mins of driving i got home and heard the radiator making funny noises. ...

  1. #1
    Junior Member TAallday's Avatar
    Join Date
    Oct 2008
    san jose, CA

    1996 camaro z28

    and i was excited for warm weather =/

    drove my 96 lt1 today and after 15mins of driving i got home and heard the radiator making funny noises. came back out and all the coolant had leaked. now my car over heats and the thermostat in the dash was over the red bars in like 10 mins of driving.. so i go buy some coolant (dex-cool 50/50 i believe) fill the reservoir tank but it still overheats on the way home. get home and fill the radiator turn the car on without closing it. as the car started to heat up coolant overflowed out of the radiator.. is it clogged? maybe the valves or the radiator its self.. or did it do that cus the radiator cap wasnt on.. any help will be greatly appreciated..

  2. #2
    Paid off 1/27/14 cammed goat's Avatar
    Join Date
    Jan 2009
    Paterson/Ridgewood, NJ

    Phantom Black Metallic
    2004 GTO M6

    Have you checked to see if your radiator split? I think coolant will overflow if the cap isn't on. I am getting many different symptoms reading the first post. Have you flushed the cooling system at all? Have you replaced the radiator cap at all?

  3. #3
    Join Date
    Nov 2009
    Norfolk, Nebraska
    2002 Camaro Z28

    Your first couple sentences make it sound like the radiator went as cammed goat mentioned. Really need to find out where the leak is before driving it much more.
    Junkyard bought and "refurbished" 2002 Camaro Z28 - Pacetter Race LT's, TS&P ORY, Frost tune, Magnaflow, Ported TB, SLP Lid, Circle D 3000, 3.73's, SFC's.
    2009 Silverado Z71 - Magnaflow
    2008 Impala LTZ - Wife didn't want the V8 SS!

  4. #4
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Bergen Co. NJ

    2000 Camaro SS Conv.

    Sounds more like thermostat or fans not kicking in. Let it cool down, fill the radiator, start it and see if the fans come on when it starts to get hot. If they do, shut it off and replace the thermostat.

  5. #5
    Join Date
    Jul 2007

    1994 camaro z28 a4

    sounds like the efans arent turning on u should check the ground same thing happened to me cause my efans werent making good contact cause i had painted the light bar

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My flat tire
    By c5z28 in forum Almost Anything Goes
    Replies: 37
    Last Post: 10-07-2009, 11:17 PM
  2. Density Altitude - Tuning For The Weather
    By Ed Blown Vert in forum Almost Anything Goes
    Replies: 9
    Last Post: 05-02-2009, 06:54 PM
  3. help with weather stripping
    By T/A 2001 in forum Appearance Section
    Replies: 7
    Last Post: 08-06-2008, 05:52 AM
  4. Clear up weather!
    By konigandy6 in forum Almost Anything Goes
    Replies: 20
    Last Post: 02-14-2008, 04:19 PM
  5. gap between window and weather seal
    By jblindy in forum Convertible
    Replies: 10
    Last Post: 12-22-2005, 09:03 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts