Page 1 of 2 12 LastLast
Results 1 to 20 of 22

How reliable is your LS1 thus far?

This is a discussion on How reliable is your LS1 thus far? within the General Help forums, part of the LSx Technical Help Section category; OK I have been through a few issues with my LS1 and wanted to ask everybody about their maitenence necessary ...

  1. #1
    Member myk02k's Avatar
    Join Date
    Sep 2005
    Location
    Mars
    Age
    29
    Posts
    534

    Black
    2002 Camaro Z28 6-spd

    How reliable is your LS1 thus far?

    OK I have been through a few issues with my LS1 and wanted to ask everybody about their maitenence necessary in order to keep the car going. I just want to prepare for future upcomings, but please don't say "oh the axle will go", just say what broke on you and when it needed replacement. Also, nothing under $100. Here's me...

    2000 A4 LS1

    bought at 48,600

    alternator RIP at 47,000
    ignition cylinder key RIP at 58,600
    4L60E A4 transmission RIP at 60,000
    water pump RIP at 61,000 (but was going for a while)

    currently 62,000 miles

  2. #2
    We'll be back... GatorSS's Avatar
    Join Date
    Aug 2005
    Location
    THE SWAMP
    Posts
    1,446

    Light Pewter Metallic
    2000 Camaro SS M6

    Quote Originally Posted by myk02k
    ...just say what broke on you and when it needed replacement. Also, nothing under $100. Here's me...
    Mine is my daily driver and has almost 94k miles on it now. I bought it brand new. Thus far, nothing has broke that was more than $100. The driver's window motor went out at about 65k miles and I bought a new one for less than $60 and replaced it myself. That's it. Needless to say, I am well pleased with my car.

    I have replaced other items with aftermarket components, but not because anything broke; I wanted more performance.

  3. #3
    Member Capster78's Avatar
    Join Date
    Dec 2005
    Location
    Newport News Va
    Age
    38
    Posts
    578

    Silver
    1998 WS6 M6

    Other highly replaced items are headlight motors, window motors, fuel pumps, 12 bolt rear ends, speakers and well if you drive like I do, tires

  4. #4
    Sideways to da next light redline's Avatar
    Join Date
    Jan 2006
    Location
    okc
    Age
    32
    Posts
    111

    black
    2000 trans am

    80,000 on mine and ive done u-joints, altinator, three p.s. pumps, rubber, and shocks. Current problems are leaky rack and pinion, bad driver side window regulator, intermitent security light, and a wonderfull rear end noise that only the radio and a blown out flowmaster can cure. still runs wot every day. (i'll drive it till the wheels fall off)

  5. #5
    Junior Member baker5209's Avatar
    Join Date
    Apr 2006
    Location
    Mich
    Posts
    25

    white
    1998 Z28

    None

    I have not had any problems with mine it has 74,345 miles. Just mods on it.

  6. #6
    Member 5LtrBtr's Avatar
    Join Date
    Aug 2005
    Location
    Oklahoma
    Age
    33
    Posts
    106

    Black
    01 Trans Am

    Bought mine with 45000 or so on it. Got 77000 now. Haven't done anything except a new set of tires and oil changes. It needs a tune up and I think the water pump is going out but thats it. No leaks sqeaks and only a slight rattle.

  7. #7
    used and abused at wot ibanez7's Avatar
    Join Date
    Aug 2005
    Location
    Crystal Lake IL
    Age
    39
    Posts
    2,517

    Pewter
    2001 Camaro Z28 M6

    2001 z28 m6. dyno 360rwhp, low 12s 1/4 time, with just bolt-ons with 100,000 miles.

    I bought the car with 20,000 on it and the car has earned another 80,000 with me driving hard, multiple track passes, street races and SCCA solo 1 races too. the car has been my daily driver for the last 3 1/2 years and the only two problems I have had is:

    waterpump went out, such an easy fix.
    Slave cylinder exploded, not so east and time consuming.

    besides that I am on the factory 10bolt and clutch

  8. #8
    Member myk02k's Avatar
    Join Date
    Sep 2005
    Location
    Mars
    Age
    29
    Posts
    534

    Black
    2002 Camaro Z28 6-spd

    wow, great responces guys keep them coming. i guess ive either had bad luck or everyone with good luck is responding.

    5LtrBtr, keep an eye on that water pump mine gave me hell before it finally went. It was going for nearly 8 months and I think I was burning coolant and it would overheat when the radiator would be near empty and act like a catalyst, evaporating even more fluid. I probably went through 6 bottles of coolant until it just gave up completely, but it would lose a lot for a month, not lose anything another month, lose more next month, ect. Just keep Dexcool wherever you go and fill it constantly until the day your car goes over 260' (itll come!), and next round use traditional green with redline or purple royal.

  9. #9
    YOW Pookie's gone postal! Motrv8d Steve's Avatar
    Join Date
    Aug 2005
    Location
    North San Diego Co.
    Posts
    1,932

    Black
    1998 Camaro Z28

    had to replace the rotors at 11K, 23K (both under warranty) and now they need replacing again at 57K.
    had to replace the M6 at 41K (never been to the track and hardly ever ever street race, maybe 5 times since 1998.
    haven't had to replace the infamous passenger window motor, but it is sloooooooow.
    other than that, haven't had any other major problems. motor runs like a raped ape.
    oh I almost forgot, my master cylinder brake system has a really slow leak that will have to be repaired/replaced soon.
    Steve
    1998 Black Z28 Pro 5.0 shifter, Borla Catback, DirectFlo Lid, !CAGS

  10. #10
    Member myk02k's Avatar
    Join Date
    Sep 2005
    Location
    Mars
    Age
    29
    Posts
    534

    Black
    2002 Camaro Z28 6-spd

    Quote Originally Posted by Motrv8d Steve
    had to replace the rotors at 11K, 23K (both under warranty) and now they need replacing again at 57K.
    had to replace the M6 at 41K
    You're lucky, I had a friend that would beat the sh** out of his Z and woke up one morning to go to school and noticed he lost a caliper...the whole damn thing was just gone from the night before.

  11. #11
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Quote Originally Posted by Motrv8d Steve
    had to replace the rotors at 11K, 23K (both under warranty) and now they need replacing again at 57K.
    had to replace the M6 at 41K (never been to the track and hardly ever ever street race, maybe 5 times since 1998.
    haven't had to replace the infamous passenger window motor, but it is sloooooooow.
    other than that, haven't had any other major problems. motor runs like a raped ape.
    oh I almost forgot, my master cylinder brake system has a really slow leak that will have to be repaired/replaced soon.
    My passenger side power window is the same way. Its really slow, but it still works, so its good enough for now

  12. #12
    Junior Member
    Join Date
    Mar 2006
    Location
    Coram, NY
    Age
    42
    Posts
    8

    Navy Blue
    2002 Camaro Z28

    I bought My 2002 Camaro Z28 A4 brand new with 77 miles on it in June 2002. I only had regular maintenance on it and replaced normal maintenance items such has front brakes, tires, filter, oil, etc. I now have 65,800 miles on it and runs still very smoothly.

  13. #13
    Got Rice? Liquifire's Avatar
    Join Date
    Aug 2005
    Location
    central wisconsin
    Age
    37
    Posts
    702
    Quote Originally Posted by myk02k
    wow, great responces guys keep them coming. i guess ive either had bad luck or everyone with good luck is responding.

    5LtrBtr, keep an eye on that water pump mine gave me hell before it finally went. It was going for nearly 8 months and I think I was burning coolant and it would overheat when the radiator would be near empty and act like a catalyst, evaporating even more fluid. I probably went through 6 bottles of coolant until it just gave up completely, but it would lose a lot for a month, not lose anything another month, lose more next month, ect. Just keep Dexcool wherever you go and fill it constantly until the day your car goes over 260' (itll come!), and next round use traditional green with redline or purple royal.
    If you know that it is going why not replace the damn thing as soon as you can and definitely before you get your temp over 260..........why would you want your motor to run that hot? If you ran it that warm for any length of time you should be thankful that is all the damage it did. There is a reason why 260 degrees is in the red when it comes to engine temps.....

  14. #14
    Member Sam-SS's Avatar
    Join Date
    Feb 2006
    Location
    Treasure Island, FL
    Age
    77
    Posts
    109

    Red
    '99 Camaro SS

    Cool

    Ok, my '99 SS w/67k miles on it that I bought new has had:

    SS spoiler tail lights @ 20k under warranty.
    Torsen Posi @ 30k under warranty to stop slow cost thrump, thrump.
    Front rotors with Pucks all around @ 50k, discovered that the dustless aftermarket
    part dusted badly.
    Pucks all around with OEM parts to stop dusting @ 55k
    Replaced shocks all around with Bielstien @ 57k.
    Blew clutch master cylinder @ 60k
    Again replaced Torsen Posi @ 61k but this time with Eaton unit. Slow coast thrump,
    thrump had returned.
    Changed plugs @ 62k. Probably not needed but I figured that 60k was enough.
    Replaced front & sail panel speakers w/Infinity @ 65k. Front needed it rear did not. I should have done this many years earlier as the Infinities are great.

    I faithfully rotate, balance, change Mobile 1, filter etc every 5k miles.

    Many mods.

    Now I have a question. How long has the OEM exhaust system been lasting for
    you folks?

  15. #15
    Junior Member
    Join Date
    Jan 2006
    Location
    CC, TX
    Age
    49
    Posts
    24

    Black
    04 Z06

    01 T/A, bought at 18,000 sold at 65,000 never gave it a rest, only had to regrind the rotors and replace one headlight motor, other than tires. Drove it hard most the time.

  16. #16
    Junior Member
    Join Date
    Jan 2006
    Location
    CC, TX
    Age
    49
    Posts
    24

    Black
    04 Z06

    Duh, and I had to replace an O2 sensor, but those are warranteed until 80k.

  17. #17
    Senior Member 02z28ls1's Avatar
    Join Date
    Sep 2005
    Location
    near St. Louis
    Posts
    1,205

    navy blue
    2002 Z-28 Camaro M6

    Bought a 98 V-6 5 speed Camaro new in 97-burnt out a foglight that was replaced under warranty. Traded it in @36,000 miles for my 02 Z-28-now at 30,000 miles. Have a foglight burn out recently and had a door speaker blow out a couple months ago (my bad). Needless to say I couldn't be happier. And I wanted to add to the guy that thinks it's a bitch that the antifreeze evaporates because he is overheating the hell out of his motor with a bad water pump that is so freakin easy to replace and so inexpensive that he is a retart for not doing it asap----YOU SPENT MORE ON ANTIFREEZE THAN IT COST TO REPLACE THE WATER PUMP!!!!!!! please get a clue:firedevil

  18. #18
    Member Huskerz1's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    46
    Posts
    947

    Black
    99 SS Vert M6

    72,000 miles

    1 water pump at 64k
    1 radiator at 70k
    NGK TR55's with MSD wires at 70k

    Daily driver
    Last edited by Huskerz1; 05-18-2006 at 09:13 PM.

  19. #19
    Member myk02k's Avatar
    Join Date
    Sep 2005
    Location
    Mars
    Age
    29
    Posts
    534

    Black
    2002 Camaro Z28 6-spd

    Quote Originally Posted by 02z28ls1
    Bought a 98 V-6 5 speed Camaro new in 97-burnt out a foglight that was replaced under warranty. Traded it in @36,000 miles for my 02 Z-28-now at 30,000 miles. Have a foglight burn out recently and had a door speaker blow out a couple months ago (my bad). Needless to say I couldn't be happier. And I wanted to add to the guy that thinks it's a bitch that the antifreeze evaporates because he is overheating the hell out of his motor with a bad water pump that is so freakin easy to replace and so inexpensive that he is a retart for not doing it asap----YOU SPENT MORE ON ANTIFREEZE THAN IT COST TO REPLACE THE WATER PUMP!!!!!!! please get a clue:firedevil
    I had no choice, I didn't have the money yet to afford a replacement and I didn't even know what was wrong with it. I thoughy maybe I had a leak because it only over-heated when the radiator was empty. Because it was so sporadic when it occured, I could never find out wtf was wrong with it. I even got the coolant pressure-checked and told the mechanic my problem and he said nothing was wrong when I did have the money...2 weeks later it blew. I was scratching my forehead and so was everybody else until the water pump finally went.

  20. #20
    Junior Member baker5209's Avatar
    Join Date
    Apr 2006
    Location
    Mich
    Posts
    25

    white
    1998 Z28

    Sam-SS i have my 98 om exhaust still on. Was gone to replace it for something with more flow after it gave out but don't think i will wait any more.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •