Results 1 to 3 of 3

How bad is this?

This is a discussion on How bad is this? within the General Help forums, part of the LSx Technical Help Section category; I was under my car and notices this sorry about the quality i only had my phone. Other side looks ...

  1. #1
    Member Mr Z's Avatar
    Join Date
    Apr 2006

    Navy Blue Metallic
    1998 T/A A4

    How bad is this?

    I was under my car and notices this

    sorry about the quality i only had my phone.

    Other side looks the same. Is this serious? What's the process on replacing?

    **sorry. when i loaded the image, it worked in the post preview...**
    Last edited by Mr Z; 09-05-2007 at 09:25 PM.

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005

    98 Formula
    06 duramax

    a pic would be nice

  3. #3
    Senior Member JonB's Avatar
    Join Date
    Sep 2006

    2005 GTO

    That is just your tie rod boot. You can get replacement ones for under $10 a side. They basically hold the grease in to keep it lubed. You need to inspect the tie rod becuase if it's been like this a long time you may not have grease in there and it has worn the parts down, then you may need new tie rods.

    Replacing the boots if farily easy just take the cotter pin out undo the nut take old boot off, put some new grease on and but new boot on. To replace the whole tie rod you have to remove cotter pin, nut and undo the outer(this is the one we have been talking about) tie rod from the inner tie rod then put the new on on. Unless you can get the new one to the exact spot where the old on was you may also need to get a front end alignment.
    05 PBM GTO
    Cold Air Inductions CAI,
    Relocated IAT with omega,
    Slp Predator tune,
    Flowmaster axle back with H pipe,
    Custom tuned TCM.
    BC Racing coil overs

    Sold 01 z28

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. bad f****** problems with my TA
    By blackbird33 in forum General Help
    Replies: 14
    Last Post: 04-24-2007, 03:52 PM
  2. Will bad 02 sensors fail emissions?
    By GottaHaveLS1 in forum General Help
    Replies: 8
    Last Post: 01-21-2007, 06:19 PM
  3. bad cats....
    By jbb6811 in forum Camaro / SS
    Replies: 4
    Last Post: 01-08-2007, 05:51 PM
  4. Replies: 2
    Last Post: 02-14-2006, 05:01 PM
  5. need body parts bad
    By stormbringer in forum Cowhands, Local Parts and Fish Bait
    Replies: 3
    Last Post: 10-06-2005, 05:56 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts