Results 1 to 7 of 7

Hood release does not work...have to pop hood by lifting on it...How to fix?

This is a discussion on Hood release does not work...have to pop hood by lifting on it...How to fix? within the General Help forums, part of the LSx Technical Help Section category; One time I slammed down my hood by accident. Now, when I pull the release lever in the car, it ...

  1. #1
    Member
    Join Date
    Aug 2005
    Location
    San Diego
    Posts
    272

    Black
    1999 Camaro Z28 (SS kit)

    Unhappy Hood release does not work...have to pop hood by lifting on it...How to fix?

    One time I slammed down my hood by accident. Now, when I pull the release lever in the car, it feels like it did nothing....BUT...I can go to my hood and lift it up manually and it opens? So, in short, when I pull the lever the hood does not lift a few inches like it use to...it looks like it is still closed, but when I use my hands I can lift it up and than release the handle to open the hood like normal...IT JUST DOESN'T POP UP ANYMORE??

    HOW DO YOU FIX THIS??? It is driving me crazy!!!!!!!!!!

  2. #2
    Senior Member ss~zoso~ss's Avatar
    Join Date
    Dec 2004
    Location
    )
    Posts
    9,128

    SS: NBM, tan top
    1998-SS, 2010 Jetta TDI

    check the alingment of the hood, (ex bodypanel spacing) that may be binding it up, if thats not it, disconnect the latch and take it out and look at it to make sure its not broke

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Sounds like the latch is a little out of adjustment and not fully releasing. Look at the bolts for evidence they've move a little.

  4. #4
    Member
    Join Date
    Aug 2005
    Location
    San Diego
    Posts
    272

    Black
    1999 Camaro Z28 (SS kit)

    Bolts on the loop againt the hood when you raise it, or bolts holding all that weird crap against the car?

    I did take a look at the cable line under the hood....you can see about an inch of it before it hides behind a black plastic cover...is this normal?

    It is such a pain when little crap like this happens! Thanks for the reply's...I will see if the bolts moved at all...I am running a few washers on it now per I have an SS hood on my Z...it was a GM SS hood, but it still has some fit probs back when I put it on years ago...but the hood never had a prob until I slammed it one day on accident...damn!

  5. #5
    Impounded YoMommasTA's Avatar
    Join Date
    Jan 2006
    Location
    ne pa
    Posts
    532
    Lube The Latch Assembly!

  6. #6
    Member
    Join Date
    Aug 2005
    Location
    San Diego
    Posts
    272

    Black
    1999 Camaro Z28 (SS kit)

    With what and where do I exactly lube? You can feel that there is something wrong...instead of feeling the handle actually lift the hood when you pull on it, it feels like it does nothing, and of course nothing lifts, but after I walk up to the hood, I can now lift it myself and it opens...it just does not feel right....something got bent or is out of place by a small fraction but I can not figure out what?

  7. #7
    Member
    Join Date
    Aug 2005
    Location
    San Diego
    Posts
    272

    Black
    1999 Camaro Z28 (SS kit)

    When standing in front of the car looking at the motor, the spring on the left side is sort of curved now instead of straigt...it was throwing the arm that sticks out off by less than 1/2 inch, but this is what was causing it. Anyone ever have there spring bend like this? Any fix or do I need to get a new one? Prob have to get a whole new assembly which means $$$ I am sure.

    Anyway, thanks for the help everyone!

    Rich

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •