Results 1 to 8 of 8

Hign engine idle

This is a discussion on Hign engine idle within the General Help forums, part of the LSx Technical Help Section category; Hi guys and gals. I am new to the LS1 world ,so please help me the best you can. I ...

  1. #1
    Junior Member
    Join Date
    Jun 2009
    Location
    Houston
    Posts
    7

    Blue
    2001

    Hign engine idle

    Hi guys and gals. I am new to the LS1 world ,so please help me the best you can. I have 01 Formula ram air. After my car is warmed up and runs for a while, it starts to idle higher and when I have it gear I can let off the accelerator and the car will keep going at the same idle. Please point me in the right direction.

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    How high is the idle going? How many miles? Any mods? You can pull the IAC motor and clean it, they build up with grime and carbon and sometimes stick. I would also clean your MAF and Throttle body while its open..
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    check your PCV hose. They like to deteriorate in this area and PCV housing right next to it. It'll cause a vacuum leak and high idle

  4. #4
    Junior Member som ss 2001's Avatar
    Join Date
    Aug 2005
    Location
    Cypress, TX
    Posts
    45

    SOM
    2001 SS

    I am having the same prob. My 01 has 195,000 miles on it and this is the only problem i have ever had on this car. I have cleaned both TB and MAF. I have replaced the IAC and the other one under it(forgot the name ) I had my o2's checked out and was told they were running fine. I've checked for vacuum leaks and nothing. I replace my pcv every other oil change. This is starting to really drive me nuts. I love driving this car, but this is not helping. I don't know what else to look at.

  5. #5
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Quote Originally Posted by som ss 2001 View Post
    I am having the same prob. My 01 has 195,000 miles on it and this is the only problem i have ever had on this car. I have cleaned both TB and MAF. I have replaced the IAC and the other one under it(forgot the name ) I had my o2's checked out and was told they were running fine. I've checked for vacuum leaks and nothing. I replace my pcv every other oil change. This is starting to really drive me nuts. I love driving this car, but this is not helping. I don't know what else to look at.
    You should start a new thread
    but how did you test? Take it to a shop where they put a sniffer to it or did you run the car and spray ether around the manifold? Ever mess w/ the manifold?

  6. #6
    Junior Member som ss 2001's Avatar
    Join Date
    Aug 2005
    Location
    Cypress, TX
    Posts
    45

    SOM
    2001 SS

    The manifold has never been messed with. I had the 02's checked out on the shops laptop. It said hp tuner. I was told they were good. what do you mean spray around the manifold?

  7. #7
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Quote Originally Posted by som ss 2001 View Post
    The manifold has never been messed with. I had the 02's checked out on the shops laptop. It said hp tuner. I was told they were good. what do you mean spray around the manifold?
    o2's aren't associated w/ vacuum leaks. If there is a leak in the manifold it will cause a higher idle, if you spray ether around suspected points of interest and there is in fact a leaking gasket you will hear the motor idle go up. Out of curiosity you ever replace your fuel filter? Don't think it would cure it but...

  8. #8
    Junior Member som ss 2001's Avatar
    Join Date
    Aug 2005
    Location
    Cypress, TX
    Posts
    45

    SOM
    2001 SS

    I change my fuel filter and pcv every other oil change. I have not heard any sucking sound coming from the motor. I will check the manifold for any leaks. Thank You.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine stuttering at Idle
    By mike171562 in forum General Help
    Replies: 25
    Last Post: 04-01-2010, 01:03 PM
  2. Help: Engine idle surge
    By Adam_94_T/A in forum General Help
    Replies: 0
    Last Post: 03-28-2010, 04:24 AM
  3. Engine Won't Idle
    By kempfer99ta in forum Classic Muscle
    Replies: 3
    Last Post: 01-24-2010, 05:57 AM
  4. Engine races At Idle
    By midnitejam in forum General Help
    Replies: 6
    Last Post: 05-13-2009, 02:36 PM
  5. engine idle trouble help!
    By larryndog in forum General Help
    Replies: 6
    Last Post: 07-20-2006, 01:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •