Results 1 to 8 of 8

High Startup Idle

This is a discussion on High Startup Idle within the General Help forums, part of the LSx Technical Help Section category; Afternoon, M6. 133,000 miles. New clutch, pressure plate, flywheel, master and slave. Over the past few weeks the car has ...

  1. #1
    Member flipsutter's Avatar
    Join Date
    May 2008
    Location
    Arkansas
    Age
    37
    Posts
    141

    White
    1999 Firehawk

    High Startup Idle

    Afternoon,

    M6. 133,000 miles. New clutch, pressure plate, flywheel, master and slave.

    Over the past few weeks the car has been acting really weird. In the morning when I start it up it idles really high. Somtimes up to 1,500 RPM. After it warms up a bit is starts to go down but never drops below 800 to 900 rpm. Even after it warms up totally. It would idle around 1k while driving but when I come to a stop it drops down to 800 or so.

    Any idea? I replaced the gaskets on the AIR system yesterday but it started before that.

    I have also cleaned the MAF. I thought about taking the Throttle Body off and cleaning it but I'm not sure its that. Could the cable be sticking?

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Clean your Idle air control motor, its on the throttle body...
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    I Drive A 95' AfterYou's Avatar
    Join Date
    Aug 2009
    Location
    Granbury, Texas
    Posts
    441

    01' Firebird Pewter
    98' Trans Am Black

    Yeah same here my idle at a stop from just starting it up is at 1000 rpm
    Then once i get going and get to a stop light i hit about 800 even for some reason

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    check for a vacuum leak. Look at the pcv hose where it enters the intake. Those like to crack on the backside of the hose. Also, look for any place post MAF that unmetered air could be entering. My money is on a vacuum leak somewhere though.

  5. #5
    Member
    Join Date
    Aug 2009
    Location
    Virginia Beach, Virginia
    Posts
    145

    Black
    2000 Pontiac Trans Am WS6

    Quote Originally Posted by 0rion View Post
    check for a vacuum leak. Look at the pcv hose where it enters the intake. Those like to crack on the backside of the hose. Also, look for any place post MAF that unmetered air could be entering. My money is on a vacuum leak somewhere though.
    Wouldn't that throw a code? I did the EGR mod on my first T/A and got a code about a vacuum leak.

    Scott

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Quote Originally Posted by NavyTATwo View Post
    Wouldn't that throw a code? I did the EGR mod on my first T/A and got a code about a vacuum leak.

    Scott
    not necessarily....I've seen vacuum leaks not throw codes more than they do throw them.

  7. #7
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Read through this thread. There may be some good info in it for you.
    high idle only when moving

  8. #8
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    Sounds like the throttle body blade is sticking open too far, I agree with you on the throttle body cleaning.

    SteveC

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. idle issues... idle high. unplugged tps runs good?
    By okiels1 in forum Firebird / WS6
    Replies: 2
    Last Post: 12-31-2016, 04:36 AM
  2. high shift points & high idle
    By Red 99 T/A in forum General Help
    Replies: 5
    Last Post: 07-26-2010, 09:04 PM
  3. high idle
    By egod in forum General Help
    Replies: 15
    Last Post: 06-16-2010, 03:34 PM
  4. High Idle?
    By bryceslu in forum General Help
    Replies: 4
    Last Post: 03-19-2010, 08:11 PM
  5. Help: Why is my idle so high?
    By clg82 in forum General Help
    Replies: 21
    Last Post: 08-27-2008, 02:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •