Results 1 to 5 of 5

high idle speed ???

This is a discussion on high idle speed ??? within the General Help forums, part of the LSx Technical Help Section category; i've just start my 98' Z28 after 4 month of storing and the motor run too high (2500rpm to 3000rpm) ...

  1. #1
    paq
    paq is offline
    Junior Member
    Join Date
    Dec 2005
    Location
    québec
    Posts
    9

    red
    98 Z28 camaro M6 hardtop

    high idle speed ???

    i've just start my 98' Z28 after 4 month of storing and the motor run too high (2500rpm to 3000rpm) when it's to idle. Before I started the engine , i've polish de MAF and the TB. I expected that i have decalibrate the MAF but after swap mine for my father's MAF, nothing have changed. Do you have an idea for that?



    thanks!



    -paq-

  2. #2
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    28
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    check for loose connectors...chances are you didnt plug in the maf senor or something around that area all the way in.

  3. #3
    Member mikeaford's Avatar
    Join Date
    Nov 2005
    Location
    Fredericksburg Va
    Age
    41
    Posts
    151

    Pewter
    01 Trans Am

    Ensure that all the clamps are tight for your hoses to the MAF and throttle body etc I had one clamp loose and it would run then die instead of idling but loose connections will make it do all kinds of freak things.

  4. #4
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Like said above check your connections and make sure you didnt break any and all is well. Pull out your IAC sensor and clean it with some crc maf cleaner.
    J
    2001 SS, Its not the car its the Driver that matters....

  5. #5
    paq
    paq is offline
    Junior Member
    Join Date
    Dec 2005
    Location
    québec
    Posts
    9

    red
    98 Z28 camaro M6 hardtop

    Tanks guys! i will check for that today (i'm now at home) and i will cross my fingers for it work propelly!


    -paq-

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Missing stall converter and idle speed
    By earsti in forum Drivetrain
    Replies: 5
    Last Post: 11-29-2006, 08:42 PM
  2. High Idle
    By T/Aboo in forum General Help
    Replies: 2
    Last Post: 05-19-2006, 07:55 AM
  3. High Idle at Coastdown
    By T/Aboo in forum General Help
    Replies: 3
    Last Post: 04-26-2006, 02:20 PM
  4. Replies: 1
    Last Post: 01-05-2006, 06:39 PM
  5. 99 camaro ss high idle...Please help!
    By flynlow32 in forum Computer & Tuning
    Replies: 7
    Last Post: 01-01-2006, 09:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •