Results 1 to 5 of 5

Hi

This is a discussion on Hi within the General Help forums, part of the LSx Technical Help Section category; i have a problem with my instrument panel lights went out last night ck the fuse and it was out ...

  1. #1
    Member camaross19973's Avatar
    Join Date
    Mar 2007
    Location
    Los Angeles
    Age
    44
    Posts
    238

    blue
    1999 camaro ss #976

    Hi

    i have a problem with my instrument panel lights went out last night ck the fuse and it was out i tryed to replace it but the new one went out to and now my milage and road trip r gone to can some one help me plz

  2. #2
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    did you replace the red # 12 fuse

  3. #3
    Member camaross19973's Avatar
    Join Date
    Mar 2007
    Location
    Los Angeles
    Age
    44
    Posts
    238

    blue
    1999 camaro ss #976

    no i havent and what does that one do

  4. #4
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    thats the complete instrument cluster fuse.. i think that is the only one red soo it wont be hard to find.

    but it controls everything on the cluser

  5. #5
    Member camaross19973's Avatar
    Join Date
    Mar 2007
    Location
    Los Angeles
    Age
    44
    Posts
    238

    blue
    1999 camaro ss #976

    ok thx ill do tomorrow

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •