Results 1 to 3 of 3

HELP!! WOT Sputtering and Hesitating

This is a discussion on HELP!! WOT Sputtering and Hesitating within the General Help forums, part of the LSx Technical Help Section category; I just bought a 99 Z28 M6 about four weeks ago. The last owner hardly ever drove it and there ...

  1. #1
    More dreams than money... Cobra Killer's Avatar
    Join Date
    Jul 2009
    Location
    Omaha
    Posts
    103

    White
    99 Z-28

    HELP!! WOT Sputtering and Hesitating

    I just bought a 99 Z28 M6 about four weeks ago. The last owner hardly ever drove it and there were no problems. About a week the car threw a few SES lights. The first code was something about secondary air injectors. I couldnt feel any drop in power or anything so I erased the code. One day later it threw another code saying something was wrong with emissions stuff. I cant remember the it code threw exactly. After that I began noticing a sputter in sixth gear at low RPM's when I would give it a little throttle. Now the problem has progressively gotten worse to where no matter what RPM when I am WOT in any gears in spits and miss fires like it is running very rich. I was told O2 sensors, EGR, and countless other options by friends. Another thing is it much worse when the car is warmed up. Coldstarts fine and doesnt hesitate or anything when under 120 degrees. Tried 160 degree thermostat but it still runs at 180 to 190 for some reason. Well I am very nervous about this being a serious problem. Any help would be appreciated. Thanks!!!

  2. #2
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Next time the SES light comes on, don't erase it. Go to Autozone or Pepboys and have them scan the OBDII for free for you and tell you what the codes are.

    Post the codes in here. This will help us help you determine what the problem could be more precisely as opposed to throwing darts at the wall.

    Misfires can be a result of MANY things. Most common are spark plugs and wires. It can also be a result of a faulty O2 sensor.

    If you are at WOT and the car is sputtering, this sounds like to me a fuel related issue, such as your fuel pump or fuel filter. I would check/replace the fuel filter first. You can also check your fuel pressure. It should read around 58PSI.

    Keep us posted.

  3. #3
    More dreams than money... Cobra Killer's Avatar
    Join Date
    Jul 2009
    Location
    Omaha
    Posts
    103

    White
    99 Z-28

    Forgot Something

    Every once in a while it will run perfect as well. I drove it from South Dakota through the Rockies back to Diego. It ran like complete shit through the Rockies but once I hit the cool desert air it ran great for about 150 miles. Also I disconnected the EGR and it didnt change anything at all. Still sputtering. I sounds like it is dumping fuel in and cant burn it all or something. I will check on the codes at Kragen tomorrow when I get off work.
    Last edited by Cobra Killer; 08-21-2009 at 09:25 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hesitating
    By lovemytaho in forum GM Trucks
    Replies: 11
    Last Post: 06-29-2014, 06:29 PM
  2. hesitating after 30 min on highway
    By jmatt07 in forum General Help
    Replies: 1
    Last Post: 05-24-2009, 04:26 PM
  3. my 98camaro z28 is hesitating when i accelerate
    By ajonesz28 in forum General Help
    Replies: 2
    Last Post: 04-09-2009, 10:23 AM
  4. Trans hesitating when I hit the gas.
    By 2001redssagain in forum Automatic Transmission
    Replies: 2
    Last Post: 10-25-2006, 11:45 AM
  5. shaking/missing/hesitating...
    By adham in forum General Help
    Replies: 26
    Last Post: 02-04-2006, 07:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •