Results 1 to 4 of 4

help with whining noise please!

This is a discussion on help with whining noise please! within the General Help forums, part of the LSx Technical Help Section category; i have a 1998 z28 with 60,000 miles. i have noticed my car makes a whining sound when idleing that ...

  1. #1
    Junior Member
    Join Date
    Jan 2006
    Location
    ga
    Posts
    7

    blue
    98' z28

    Exclamation help with whining noise please!

    i have a 1998 z28 with 60,000 miles. i have noticed my car makes a whining sound when idleing that sounds like it could possibly be coming from the fuel pump area but not completely sure because i have listened up under the hood and can hear it a little too. the funny thing is that it never happens (the whining) when i first get into my car like going to work in the mornings but as soon as i stop somewhere and cut the car off and get back in to leave, it makes the noise but only at idle, i can put the car in drive and as soon as i take off the noise stops. it is never a constant whine at idle, the noise starts and lasts for maybe 10 seconds and goes off and when the noise happens it is like a fan kicking on because i can see my volts surge down for a split second but it is not the fan. i just recently put loudmouth pipes on the car and can sort of hear the noise through the exhaust. i just bought a new fuel filter but have not put it on yet. i thought it might be stopped up and the fuel pump is struggeling. and one more thing- after about a week of sitting i crunk the car up and it fired up fine but it was just sruggeling (bogging down) but as soon as i gave it a little gas it was 100% fine. any advise would be greatly appreciated. thanks!

  2. #2
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    NorCal
    Age
    35
    Posts
    1,876

    RED
    1998 Pontiac Trans AM

    It could possibly be the EGR valve or the AIR system. I had that issue on my 98 with the EGR and it was basically the solenoid not opening up. That's the best I can tell you. Are you throwing any sort of codes or anything?

  3. #3
    Junior Member
    Join Date
    Jan 2006
    Location
    ga
    Posts
    7

    blue
    98' z28

    throwing codes???

  4. #4
    Junior Member
    Join Date
    Jan 2006
    Location
    ga
    Posts
    7

    blue
    98' z28

    sorry i had to do some research. no codes have been popping up. i guess i need to check around my egr tube.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •