Results 1 to 11 of 11

Help Unknown Broken Sensor

This is a discussion on Help Unknown Broken Sensor within the General Help forums, part of the LSx Technical Help Section category; Ok so I blew a head gasket so I have started to take apart my motor to fix it. Today ...

  1. #1
    Member MikeMoss's Avatar
    Join Date
    Jan 2007
    Location
    Kansas
    Posts
    106

    Rally Red
    2001 Camaro B4C

    Help Unknown Broken Sensor

    Ok so I blew a head gasket so I have started to take apart my motor to fix it. Today I got the Intake Manifold off and when I pulled it out I found a small black cylinder with a plug on it. It looks pretty important.

    My question is what is this sensor so that I can get a new one.

    http://photos-c.ak.facebook.com/phot...82154_1017.jpg

    http://photos-d.ak.facebook.com/phot...82155_1288.jpg

    http://photos-a.ak.facebook.com/phot...82156_1577.jpg
    This is where it came from I am pretty sure.

    Thanks

  2. #2
    Blown, Stroked, & Sprayed

    Ed Blown Vert's Avatar
    Join Date
    Aug 1999
    Location
    San Diego, Ca
    Posts
    50,748

    Black
    383 Procharged & N20 Vert

    Oil Pressure sensor.
    Black 1999 Blown Convertible A4
    Forged 383, ATI D-1SC
    NX MAF Kit | 222/226 .585 115
    AS Stage II 6.0L FI Heads
    Moser 9" | 3.70 | Wavetrac | 35 Spline | Vigilante 3600
    548.0 RWHP - 563.8 RWTQ - 10# - D1

    666.0 RWHP - 734.2 RWTQ - 125 Shot - P1

    Black 2009 Escalade Hybrid 4WD
    Black 2008 GMC Yukon Hybrid 4WD (Totaled)

    Black 2013 Chevy Volt (Gone)

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Yep, replace it before putting the intake back on - much easier.

  4. #4
    Member MikeMoss's Avatar
    Join Date
    Jan 2007
    Location
    Kansas
    Posts
    106

    Rally Red
    2001 Camaro B4C

    ok thanks, when I saw this thing off the back of the motor broken I was thinking that it would be a pretty big deal

    thanks

  5. #5
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    welcome to the broken oil pressure senders club........many of us in the club already. I busted mine doing an intake swap the first time.

  6. #6
    Member MikeMoss's Avatar
    Join Date
    Jan 2007
    Location
    Kansas
    Posts
    106

    Rally Red
    2001 Camaro B4C

    Ok so how do I put the new one in. Cant get a wrench on it and it is too tall to use a socket. and it is like 1 and 1/16.

  7. #7
    Senior Member Wheeler99WS6's Avatar
    Join Date
    Jul 2006
    Location
    indiana
    Age
    35
    Posts
    1,018

    black, 05 Roush
    black, 99 T/A WS.6

    there is a socket made specifically for oil pressure sending unit. i will sell you mine if you like. i dont plan using it again.
    1999 T/A WS6 Black -------SOLD
    05 mustang Roush sport;
    DOB manifold, m122 SC, 47lb injectors, gt500 TB, roush TVS CAI, Detroit rocker SC grind camshafts, Mac LTs, off road x, roush off road mufflers, roush short throw shifter, kenne bell BAP, Brenspeed 93 octane tune. 479rwhp 436ftlbs SAE.

  8. #8
    Awaiting Activation
    Join Date
    Aug 2007
    Location
    strattanville pa
    Posts
    54

    black
    2004 gto

    Quote Originally Posted by Wheeler99WS6 View Post
    there is a socket made specifically for oil pressure sending unit. i will sell you mine if you like. i dont plan using it again.
    and about the time you sell it youll break it and need it....lol

  9. #9
    Member MikeMoss's Avatar
    Join Date
    Jan 2007
    Location
    Kansas
    Posts
    106

    Rally Red
    2001 Camaro B4C

    I got it in being very patient with some needle nose Vicegrips.

  10. #10
    Senior Member Wheeler99WS6's Avatar
    Join Date
    Jul 2006
    Location
    indiana
    Age
    35
    Posts
    1,018

    black, 05 Roush
    black, 99 T/A WS.6

    Quote Originally Posted by GTO_Kroh View Post
    and about the time you sell it youll break it and need it....lol
    yeah that sounds about how my luck is. haha

    Quote Originally Posted by MikeMoss View Post
    I got it in being very patient with some needle nose Vicegrips.
    Sweet....I bet that took forever.

  11. #11
    Member MikeMoss's Avatar
    Join Date
    Jan 2007
    Location
    Kansas
    Posts
    106

    Rally Red
    2001 Camaro B4C

    [/QUOTE]Sweet....I bet that took forever.[/QUOTE]

    Yea like at least an hour.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Oil pan level sensor (broken wires)
    By allbaugh_04 in forum General Help
    Replies: 10
    Last Post: 05-02-2011, 06:44 AM
  2. unknown vibration
    By JROBINSON1016 in forum Internal Engine
    Replies: 6
    Last Post: 05-07-2009, 06:41 PM
  3. Replies: 1
    Last Post: 05-02-2006, 10:58 AM
  4. 99 firebird vs unknown gto
    By 04goatinmass in forum Kill Stories
    Replies: 19
    Last Post: 03-03-2006, 02:12 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •