Results 1 to 3 of 3

help troubleshooting

This is a discussion on help troubleshooting within the General Help forums, part of the LSx Technical Help Section category; here is the problem my car is having, when there is load on the engine the volts drop down to ...

  1. #1
    N/A nitrously aspirated stangslayer98's Avatar
    Join Date
    Nov 2005

    1998 trans am

    help troubleshooting

    here is the problem my car is having, when there is load on the engine the volts drop down to a point where the cars electronics dont work and it shuts down.....things i have done new battery and alternator, and i still keep having that issue please any ideas of what it can be?

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006

    2002 WS6

    Sounds like the alternator isn't getting enough voltage, check the ground and exciter wire off the back of it. From what I have seen due to lovation and such the wire and connector get damaged easily.

    After thought, check the tensioner and make sure that hasn't come lose and causeing the belt to slip.
    Last edited by Orcus79; 12-11-2008 at 09:48 PM.

  3. #3
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Bragg NC

    Met. Sunset Orange
    01 SS

    I agree with above, alt working with ya. Also check your terminals and enusre there good and tight and clean, and the main ground is tight and clean.
    2001 SS, Its not the car its the Driver that matters....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Troubleshooting Cruise control
    By 2MuchFun in forum General Help
    Replies: 4
    Last Post: 08-27-2007, 08:14 PM
  2. troubleshooting help!!
    By 2MuchFun in forum General Help
    Replies: 0
    Last Post: 08-16-2007, 02:28 PM
  3. Procharger Troubleshooting (HELP!)
    By DSWitherow in forum Forced Induction
    Replies: 13
    Last Post: 08-14-2007, 01:42 PM
  4. Troubleshooting HSW Dry Kit
    By ProwlerZ in forum Nitrous
    Replies: 10
    Last Post: 04-17-2007, 06:32 PM
  5. Need help troubleshooting a problem!
    By jrbonds in forum LT1
    Replies: 17
    Last Post: 01-28-2007, 05:32 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts