Results 1 to 7 of 7

Help with Tie-rod end - is it supposed to look like this?

This is a discussion on Help with Tie-rod end - is it supposed to look like this? within the General Help forums, part of the LSx Technical Help Section category; I raised the front drivers side of my '99 Z28 convertible to look for a leak in the power steering ...

  1. #1
    Member
    Join Date
    Aug 2005
    Location
    Woodbridge, VA
    Age
    52
    Posts
    122

    Navy Blue Metalic
    1999 Z28 Convertible

    Help with Tie-rod end - is it supposed to look like this?

    I raised the front drivers side of my '99 Z28 convertible to look for a leak in the power steering system, and noticed that the sway bar end looked odd (see picture). When I lowered the car, it seemed to seat properly again. Is it normal for the sway bar end to look like this when the car is jacked up?
    Attached Images Attached Images
    Last edited by Neil; 05-31-2013 at 07:30 AM.

  2. #2
    Sold: LS1 '85 El Camino ls1camino's Avatar
    Join Date
    Dec 2005
    Location
    Laurel, Maryland
    Posts
    4,977

    2000 Grand Prix GTP
    2000 Trans Am WS6 M6

    Sway bar end link*, and that looks fine. Rubber is hard and takes the shape of how it sits most of the time. When you jacked it up, the sway bar moved and the rubber stayed in place. As long as nothing is broken and the rubber isn't dry rotted, you're fine.

  3. #3
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    the end links are not rubber anymore............stockers were a poly type material......for peace of mind i would replace them

  4. #4
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    Did you find the PS leak ?
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

  5. #5
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Almost looks like the endlink wasn't tightened at all.

  6. #6
    expensive tires az gt eater's Avatar
    Join Date
    Mar 2006
    Location
    phoenix
    Posts
    1,951

    white
    04 2500 4x4 crew cab

    Is the rubber still there above the sway bar end link? It is hard to see in the picture. I have never looked at mine while it was in the air. I can say that when I changed all those rubber pieces out for poly, there wasn't much left of them. Made a noticable difference in handling just by changing all that rubber out....

  7. #7
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by az gt eater View Post
    Is the rubber still there above the sway bar end link? It is hard to see in the picture. I have never looked at mine while it was in the air. I can say that when I changed all those rubber pieces out for poly, there wasn't much left of them. Made a noticable difference in handling just by changing all that rubber out....
    Yeah I noticed i big difference in handling when I replaced those too. Did you replace the sway bar bushings for polys as well?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Supposed to run a 5.0 on a 200 shot
    By MrMasterCraft in forum Kill Stories
    Replies: 36
    Last Post: 01-02-2011, 08:31 PM
  2. Is this supposed to happen???
    By 10spokess in forum Camaro / SS
    Replies: 12
    Last Post: 12-08-2009, 05:51 PM
  3. Supposed to snow tomorrow....
    By Mr. Luos in forum Almost Anything Goes
    Replies: 9
    Last Post: 02-27-2009, 12:06 PM
  4. is the car supposed to act like this
    By purplebat66 in forum General Help
    Replies: 14
    Last Post: 06-11-2008, 08:08 PM
  5. your supposed to be............
    By zero_proto in forum Western Members
    Replies: 46
    Last Post: 01-23-2007, 12:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •