Results 1 to 4 of 4

Help...rough idle, loss of power

This is a discussion on Help...rough idle, loss of power within the General Help forums, part of the LSx Technical Help Section category; So I was driving home from thanksgiving dinner and my car suddenly began idling roughly. It also was louder and ...

  1. #1
    Junior Member
    Join Date
    Sep 2005
    Location
    California
    Posts
    8

    Black
    2001 Camaro SS

    Help...rough idle, loss of power

    So I was driving home from thanksgiving dinner and my car suddenly began idling roughly. It also was louder and had a significant loss of power. It still runs but I am afraid to drive it anywhere and am getting it towed in the morning. I don't want to get ripped off at the dealership because I am not a motor guru and am wondering if you guys can offer any advice based on these symptoms. Thanks alot and happy thanksgiving. Oh and by the way this is a suburban, my SS is in shop.

  2. #2
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    What motor and year suburban?

  3. #3
    Junior Member
    Join Date
    Sep 2005
    Location
    California
    Posts
    8

    Black
    2001 Camaro SS

    1996 2500... the dealer says it is a problem with one of the cats and is just a huge exhaust leak...

  4. #4
    Kill Whore LS1What's Avatar
    Join Date
    Nov 2005
    Location
    West MI
    Age
    31
    Posts
    188

    Red
    '85 GT

    Quote Originally Posted by SSlow
    1996 2500... the dealer says it is a problem with one of the cats and is just a huge exhaust leak...
    Yeah, makes sense... That's the only reason it's get loud... The exhuast leak that is. Plugged cat will make it run like shit for sure, and can cause a leak..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. *** Happy New Year TRAIN!! ***
    By Ed Blown Vert in forum AAG Archives
    Replies: 15361
    Last Post: 12-31-2005, 11:10 PM
  2. rough idle
    By 98redbird in forum General Help
    Replies: 3
    Last Post: 11-11-2005, 08:53 PM
  3. Exhaust Y Pipe Question...Power Loss?
    By HiLL99SS in forum External Engine
    Replies: 11
    Last Post: 09-28-2005, 06:53 PM
  4. Serious hp loss. Run'n extremely rich., Need some expert advise
    By nitenshinarmor in forum External Engine
    Replies: 6
    Last Post: 08-26-2005, 12:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •