Results 1 to 5 of 5

HELP! right turn signal doesnt work! (2000 WS.6)

This is a discussion on HELP! right turn signal doesnt work! (2000 WS.6) within the General Help forums, part of the LSx Technical Help Section category; i noticed half way from florida to kentucky that my right turn signal stopped working, the green arrow indicating my ...

  1. #1
    Junior Member
    Join Date
    Nov 2010
    Location
    Spring Hill, FL/ Campbellsville, KY
    Posts
    32

    Red
    2000 Trans Am WS.6

    HELP! right turn signal doesnt work! (2000 WS.6)

    i noticed half way from florida to kentucky that my right turn signal stopped working, the green arrow indicating my signal is on doesnt blink, it stays solid green while the turn signal is engaged to the right. the left works fine, but the right doesnt. front and rear signals are out on the right side so i dont think its the bulbs... maybe a fuse? suggestions???

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    It wouldn't be a fuse because both sides share the same turn signal fuse. It could the turn signal switch or maybe it is the bulbs. hit the four way hazards and walk around to see if the bulbs work

  3. #3
    Senior Member Schmalgar's Avatar
    Join Date
    Apr 2010
    Location
    Alpharetta, Ga
    Age
    45
    Posts
    1,060

    04 Cobra 'vert - M6 mysti
    02 WS6 coupe - A4 red

    Do you mean that front and rear turn signals are out? Or that front and rear lights are out? If you mean just the turn signals, yes that is caused by the front running light bulb being bad. It's one of the most annoying problems with our cars. Did you drive through any rain? It doesn't take much water at all to get into the light casing and short out the bulb.

    If this is the issue, when you replace the bulb, put some dielectric grease in the socket, that will help keep it from happening again. There are more permanent solutions, like replacing the lens casing and lining it with silicon to help prevent it from cracking...

  4. #4
    Junior Member
    Join Date
    Nov 2010
    Location
    Spring Hill, FL/ Campbellsville, KY
    Posts
    32

    Red
    2000 Trans Am WS.6

    Quote Originally Posted by Schmalgar View Post
    Do you mean that front and rear turn signals are out? Or that front and rear lights are out? If you mean just the turn signals, yes that is caused by the front running light bulb being bad. It's one of the most annoying problems with our cars. Did you drive through any rain? It doesn't take much water at all to get into the light casing and short out the bulb.

    If this is the issue, when you replace the bulb, put some dielectric grease in the socket, that will help keep it from happening again. There are more permanent solutions, like replacing the lens casing and lining it with silicon to help prevent it from cracking...
    the front and rear turn signal on the right side wont go on when i turn the right side on, and the green arrow in the dash that indicates them being on, stays solid green and doesnt make the normal click noise, until i return the turn signal,then the green arrow goes away but no resonse on the outside of the car? i havent tried the hazard, didnt think of that. im gonna try it now as i go out, but my front left headlight (lowbeam) is out too but i dont see that affecting anything?

  5. #5
    Senior Member Schmalgar's Avatar
    Join Date
    Apr 2010
    Location
    Alpharetta, Ga
    Age
    45
    Posts
    1,060

    04 Cobra 'vert - M6 mysti
    02 WS6 coupe - A4 red

    Yep that's almost certainly a blown bulb in the front. The headlight is probably just coincidental. Also, as these are dual filament bulbs, sometimes the running lamp will be on which may make you think it's not a bulb issue. But one filament may still be working while the other has blown...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Front Turn Signal/Running lamps don't work
    By scStormChaser in forum General Help
    Replies: 11
    Last Post: 04-12-2015, 06:54 PM
  2. Replies: 3
    Last Post: 12-16-2014, 03:35 AM
  3. Radio doesnt work but CD player does....
    By cujo in forum Stereo and Electronics
    Replies: 16
    Last Post: 11-15-2009, 10:58 AM
  4. Front turn signal wont work?
    By 95camaroZNC in forum General Help
    Replies: 6
    Last Post: 09-13-2009, 06:45 PM
  5. key fob doesnt work!!
    By camd98z in forum Stereo and Electronics
    Replies: 3
    Last Post: 08-09-2006, 11:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •