Results 1 to 8 of 8

Help please

This is a discussion on Help please within the General Help forums, part of the LSx Technical Help Section category; My car started today and then died. It acted like a new battery was installed. I let it idle for ...

  1. #1
    Junior Member
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    54

    Pewter
    2000 Z-28

    Help please

    My car started today and then died. It acted like a new battery was installed. I let it idle for 2 mins then turn ac on and idle for 2 mins. Idle was normal 650 then put in gear and died.

    Car has 110k and ran fine yesterday. Any ideas?

    Thanks.

  2. #2
    expensive tires az gt eater's Avatar
    Join Date
    Mar 2006
    Location
    phoenix
    Posts
    1,951

    white
    04 2500 4x4 crew cab

    Did you try reading codes?
    Quote Originally Posted by SiggyZ View Post
    Try roasting your crow. It'll be easier to get down.
    Quote Originally Posted by GTP231 View Post
    I like grilling mine with a nice brown sugar based rub

  3. #3
    Junior Member
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    54

    Pewter
    2000 Z-28

    I am not getting a chk eng light. I started up this afternoon and it ran fine. Lol. Maybe it's a fuel filter or the pump?

  4. #4
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Your motor doesnt have to have a check engine light to have a code thrown.

    Your filter could be clogged up, or you could have a bad relay.

  5. #5
    Junior Member
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    54

    Pewter
    2000 Z-28

    Ok. Will take it to pep boys for a free read. Bought filter yesterday and will install today (I hope). Did not realize codes are thrown w/o a light. Guess that's why they call them "idiot" lights. Lol

    Thanks. I will provide results when completed.

  6. #6
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Thumbs up

    Quote Originally Posted by milleniumz View Post
    Ok. Will take it to pep boys for a free read. Bought filter yesterday and will install today (I hope). Did not realize codes are thrown w/o a light. Guess that's why they call them "idiot" lights. Lol

    Thanks. I will provide results when completed.
    Sometimes it won't throw a SES light but the ECM/PCM, err whatever, lol will log the code which can then be read and cleared @ most auto parts for free.. I had an intermitant misfire this past winter and got no SES light, just a log of the issue.. It was'nt till later when I "forced" it to throw a SES light which then promptly went out before I got to the auto parts.. Almost a $1000.00 in new parts, and exploretory surgery before I found the whole trouble was a 26 dollar coil issue.. Tho I remedied the appearant gasket issue I discovered too.. Now I've got a shelve with new parts waiting for my next build.. Good luck Definetly change out the fuel filter.. As a choked out pump will not like to be alive for long if it can't get the fuel up and out.. Trust me changing your fuel pump is not fun @ all..
    Last edited by Smittro; 09-15-2010 at 01:56 AM.
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  7. #7
    Junior Member
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    54

    Pewter
    2000 Z-28

    Changed fuel filter and drove around the block. Will take it to chk code tomorrow. Hopefully it was just the filter. I have had the car since new and for the life of me I don't remember changing the filter. I know it has not been done since I move to Florida 6 yrs ago! Lol.

  8. #8
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by milleniumz View Post
    Changed fuel filter and drove around the block. Will take it to chk code tomorrow. Hopefully it was just the filter. I have had the car since new and for the life of me I don't remember changing the filter. I know it has not been done since I move to Florida 6 yrs ago! Lol.
    Hopefully!

    When you get it checked, right all the codes down and have them clear it, that way if the problem reoccurs, you'll get the code that's potentially causing the problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •