Results 1 to 9 of 9

Help with pinging problem

This is a discussion on Help with pinging problem within the General Help forums, part of the LSx Technical Help Section category; I have a 99 T/A with basic mods (flowmaster, K&N cold air, mild tune - egr/air off, fan speeds, a ...

  1. #1
    Junior Member
    Join Date
    Oct 2007
    Location
    Yulee, FL
    Posts
    26

    Help with pinging problem

    I have a 99 T/A with basic mods (flowmaster, K&N cold air, mild tune - egr/air off, fan speeds, a little touch here and there).

    Now that the cool weather has arrived I have a horrible ping under heavy throttle. Sounds pretty bad. I first suspected that I had a bad tank of fuel so I waited out on the tank and re-filled with good premium and it is still pinging. The car has been well maintained. Recent plugs (NGK TR55), injection cleaning, fuel filter.

    Fuel pressure at the rail is 52psi with ignition on and 62psi running. Any ideas?

  2. #2
    Junior Member
    Join Date
    Feb 2006
    Location
    GARDEN GROVE, CA
    Age
    44
    Posts
    95

    BLACK
    2002, CAMARO Z28

    Try cleaning the mass air sensor. Pickup some CRC maf cleaner at Pep Boys or just use electrical contact cleaner.

  3. #3
    Member
    Join Date
    Nov 2006
    Location
    Earth
    Posts
    215
    I often wonder if some engine knock is associated with one or more injectors that are not operating correctly.

  4. #4
    Junior Member
    Join Date
    Oct 2007
    Location
    Yulee, FL
    Posts
    26
    Any other ideas....cool weather, fans come on at 180, good fuel, tune-ed up

  5. #5
    Member
    Join Date
    Oct 2005
    Location
    calif.
    Posts
    213
    I see you have the EGR turned off mechanically--The EGR table in the computer ADDS timing throughout the entire RPM range--If you don't delete the added timing in the EGR table--it will ping horribly because the EGR is not functional--You will need to have a tuner "0" out the entire EGR timing table-
    You may have other isuues--but i would start there---

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    a datalog would be really helpful. tblu92 is right though, if they didn't pull timing for the EGR that could be the source of some of your ping. Back in the ls1edit days there wasn't an egr table and when I pulled my egr I had all kinds of knock. I had to go through the high octane table and calculate where my timing was being referenced and pull timing in those cells. PIA compared to what hptuners lets you do now.

  7. #7
    Junior Member
    Join Date
    Oct 2007
    Location
    Yulee, FL
    Posts
    26
    I installed a Hypertech tune and that took care of it. The HPtuner at the hands of a professional was able to turn off EGR and zero at the tables.

  8. #8
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    i'm the one that did his tuning. i'm looking at his high octane table right now.

    from 2200-8000 rpms in the .52 - 1.20 g/cyl block, it is all set at 26*

    EGR correction table zero'ed out.

    now, i did just see something odd. the low octane table is all screwed up. for some reason, it is in the 45* range. guess i need to get back with you one day and reupload another file. don't know how i missed that.

    it's making me wonder why it's going into the low octane table.

  9. #9
    tattoo artist,esquire sic2001's Avatar
    Join Date
    Dec 2005
    Location
    Huntington Beach, California
    Age
    48
    Posts
    416

    navy blue metallic
    2001 trans am

    Im having the same problem, detonation at medium to heavy throttle. My fuel pressure drops 10lbs when I punch it. I did just have heads and cam installed and we tried to tune it with my Vinci tuner but once we saw the fuel drop we figured that was it. Could it be something else?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: High RPM Pinging
    By ezip in forum Internal Engine
    Replies: 16
    Last Post: 08-27-2010, 05:59 PM
  2. Pinging problem
    By shepss217 in forum General Help
    Replies: 10
    Last Post: 06-26-2010, 02:53 PM
  3. Pinging
    By david68 in forum General Help
    Replies: 8
    Last Post: 08-22-2008, 04:50 PM
  4. Pinging - tune problem?
    By Jglisson in forum Computer & Tuning
    Replies: 2
    Last Post: 11-24-2007, 07:44 AM
  5. Pinging Problem
    By FormulaFiend in forum General Help
    Replies: 7
    Last Post: 08-12-2006, 09:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •