Results 1 to 2 of 2

Help P1637

This is a discussion on Help P1637 within the General Help forums, part of the LSx Technical Help Section category; Generator L-terminal circuit I've done some searching and it seems to be that I need to replace the connector and ...

  1. #1
    Senior Member JonB's Avatar
    Join Date
    Sep 2006
    Location
    Florida
    Age
    32
    Posts
    1,458

    Black
    2005 GTO

    Help P1637

    Generator L-terminal circuit

    I've done some searching and it seems to be that I need to replace the connector and the red wire that is connected to it. So where does this red wire connect to? I thought I saw that it connects to the pcm but where on the pcm? Also is this the end all cure all fix for this code or could it be my alt going bad? The voltage runs low and the check guage light is on at idle but once I get going it goes off but the voltage is still low(just barley in the red).

    Thanks
    Jon
    05 PBM GTO
    Cold Air Inductions CAI,
    Relocated IAT with omega,
    Slp Predator tune,
    Flowmaster axle back with H pipe,
    Custom tuned TCM.
    BC Racing coil overs


    Sold 01 z28

  2. #2
    Member ultra_badass's Avatar
    Join Date
    Mar 2007
    Location
    Corpus Christi
    Posts
    257

    navy blue matallic
    2000 WS6 trans am M6

    i got the same thing but since it doesnt throw the SES light i dont worry about it everything runs normal with the Atl putting out 14.1-14.8 so i dunno but it would help to get ride of this code

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trouble code P1637, Help! What is it?
    By ryan_gilson in forum General Help
    Replies: 3
    Last Post: 04-11-2006, 11:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •