Results 1 to 2 of 2

HELP P0154 O2 Sensor Circuit No Activity Detected

This is a discussion on HELP P0154 O2 Sensor Circuit No Activity Detected within the General Help forums, part of the LSx Technical Help Section category; I recently installed long tube headers along with a ORY and Magnaflow catback on my 99 firebird formula. I also ...

  1. #1
    Junior Member
    Join Date
    Nov 2009
    east coast

    1999 firebird Formula

    HELP P0154 O2 Sensor Circuit No Activity Detected

    I recently installed long tube headers along with a ORY and Magnaflow catback on my 99 firebird formula. I also had the computer tuned by frost who deleted the rear O2s, Air, and EGR. I got everything hooked back up with the O2 extensions and I keep getting O2 Sensor Circuit No Activity Detected (Bank 2 Sensor 1)
    SES code. I checked all of the connections on my first ( AC Delco AFS 98) O2 sensor and noticed that there were two wires disconnected from my wiring job. Re connected everything and still getting the code after driving a couple miles. I removed this O2 sensor and used one of the Rear O2's (AC Delco AFS 97) and this one worked for around 60 miles until the plug got disconnected from the harness in this recent flooding going on in RI. Because i was dragging the connector through three feet of water i assumed that it would be shorted but tryed reconnecting it anyways. Plugged it back in worked for around 10 miles and P0154 SES code came on. Yesterday i removed that o2 sensor and used my last sensor that came off my car before the install (AC Delco AFS 98) drove 10 more miles today and the SES light came on again. I am really puzzled here. I have no idea what the problem is. I tried three different sensors and the only one that i have minor luck with was AFS97 which is the correct senosr for the passenger side header. I was told that the only difference between the sensor numbers is the length. Beacuse i have to extend them anyways it should not matter. I checked the fuses and everything appears to be okay. The only other thing i can think of is that i have the passesnger header plugged into the rear O2 harness. Can anyone specify the locations of the header and rear O2 sensors on the passengers side? Any other ideas would be helpful. Thanks

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Madison, WI

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    both front O2 sensors plug into connectors that are right on the K-member near the engine oil pan.
    Also O2 extensions are sometimes problematic. The best solution is to use the Bosch 13111 O2 sensor. It has really long wiring (no need for extensions) and tends to be more reliable then extensions. If you go to a parts store and they don't know what you mean when you ask for a Bosch 13111, then ask for a rear O2 sensor for a 2001 Corvette.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Sticky....maybe!!
    By blackSS01 in forum General Help
    Replies: 18
    Last Post: 02-13-2010, 07:08 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts