Results 1 to 7 of 7

HELP! new o2 sensors even worse

This is a discussion on HELP! new o2 sensors even worse within the General Help forums, part of the LSx Technical Help Section category; I have a 2000 ram air. had a dead spot @ 2500 rpm. The check engine light came onand was ...

  1. #1
    Junior Member
    Join Date
    Jan 2011
    Location
    south chicago heights
    Posts
    5

    taupe
    2000 ram air t/a

    HELP! new o2 sensors even worse

    I have a 2000 ram air. had a dead spot @ 2500 rpm. The check engine light came onand was diagnosed as both front o2 sensors were bad. Changed them and car is running EVEN WORSE! need help please

  2. #2
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by sirzephyr View Post
    I have a 2000 ram air. had a dead spot @ 2500 rpm. The check engine light came onand was diagnosed as both front o2 sensors were bad. Changed them and car is running EVEN WORSE! need help please
    Did you reset the codes and re check to see if a new code came up? Did you replace the sensors with the same one you had?

    Reset the codes (if you didnt) and rescan for codes again and post them here. there could be another problem that did not show before.

  3. #3
    Junior Member
    Join Date
    Jan 2011
    Location
    south chicago heights
    Posts
    5

    taupe
    2000 ram air t/a

    Did not reset codes and went with the bosch rather than ac delco. really dont know how to reset for o2 codes. ty for info, had to or would have responded asap.

  4. #4
    Junior Member
    Join Date
    Jan 2011
    Location
    south chicago heights
    Posts
    5

    taupe
    2000 ram air t/a

    btw, check engine light is not coming on wich is why i'm so confused.

  5. #5
    Junior Member
    Join Date
    Jan 2011
    Location
    south chicago heights
    Posts
    5

    taupe
    2000 ram air t/a

    sry , put in aftermarket and did not reset codes, dont know how.

  6. #6
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Who diagnosed both precat sensors bad at the same time? Do you have the original codes? How long since replacement? Some codes won't illuminate the MIL until 3 or 4 consecutive failures. I'm with JayTA98, something else is going on.

  7. #7
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    OK, if you don't have a scan tool you can reset the PCM manually this way:

    Turn key on, don't start car
    Pull PCM BATT and PCM IGN fuses in engine compartment
    Wait 5-10 min
    Turn ignition off
    Replace fuses

    Idle will be a little grumpy until it relearns, but it'll clear all codes. If the MIL lights they'll be current codes.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. It get's worse, way, way, worse
    By SMWS6TA in forum Almost Anything Goes
    Replies: 6
    Last Post: 07-10-2011, 06:23 AM
  2. Bad got worse..
    By BadBlueBird* in forum Almost Anything Goes
    Replies: 23
    Last Post: 09-08-2009, 01:05 PM
  3. In you're opion, which is worse?
    By WhiteHotSS in forum Almost Anything Goes
    Replies: 27
    Last Post: 09-03-2009, 12:07 PM
  4. Better or Worse???
    By Camaros710102 in forum Appearance Section
    Replies: 25
    Last Post: 08-10-2007, 09:47 PM
  5. Which is worse????
    By tornado in forum Almost Anything Goes
    Replies: 6
    Last Post: 04-11-2006, 08:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •