Results 1 to 12 of 12

Help! My Car Is Stalling! Need Help Asap

This is a discussion on Help! My Car Is Stalling! Need Help Asap within the General Help forums, part of the LSx Technical Help Section category; So im selling my 99 transam with headers/cb/lid/underdrive pulley/rearend that has 108000 miles on it.and i have a guy wanting ...

  1. #1
    Junior Member
    Join Date
    Jul 2007
    Location
    ohio
    Posts
    96

    silver
    99 Trans Am

    Help! My Car Is Stalling! Need Help Asap

    So im selling my 99 transam with headers/cb/lid/underdrive pulley/rearend that has 108000 miles on it.and i have a guy wanting to buy it tomorrow with cash but now it just HAS a f'n problem. When i accelerate or give it gas, it SOMETIME wants to stall out. But if i put it in N, start it back up, it works perfectly. it happens only once in a while, never at cruse, only when i floor it. it hasent done it in like 3 days but now its did it 2ce comming home. its like everytime i accelerate hard it seems like its starved of fuel and wants to stall.. it use to do it on start up but now its doing it when its warmed up.
    i need help fast to figure out what it is. no codes being thrown and oil pressure is fine. HELPPPP pleasee!!!!
    i think its a fuel problem. could it be a clogged fuel filter? maybe clogged injectors? i dont think anythings broke because it runs fine after it does it, and it only does it sometimes.

  2. #2
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Was it tuned? Fuel filter is cheap and fast so I suggest buying one of those to try it out.
    My TPS sensor started letting me drop down to under 400 rpm before it threw a code and went out, so it might be that..

  3. #3
    Junior Member
    Join Date
    Jul 2007
    Location
    ohio
    Posts
    96

    silver
    99 Trans Am

    no codes where thrown when i put the headers on and deleated the cats no codes were thrown either so i think it was tuned b4 me, the guy b4 me replaced the rearend and had a hole drilled in the side of the TB, as well as running 2 degree colder spark plugs..

    im reading a few things..
    fuel filter?
    vacum leak?
    exhaust leak?
    o2 sensors?
    MAF sensor?
    ground wire disconnecting form heads? i donno really what that ment but one guy on here at that problem..

    any of these be the problem? this guy wants to look at it tomorrow and i cannot take it there like this..

  4. #4
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Where is this hole in the TB?

    And after headers it needs to be tuned again.

  5. #5
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    You are going to have to get it hooked up to a computer to see exactly what is going on, you could also try cleaning your IAC motor..
    J
    2001 SS, Its not the car its the Driver that matters....

  6. #6
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    fuel filter would be a cheap/easy stab @ it

  7. #7
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    is the "SES" light on??? have oyu checked you air filter to make sure it is clean???

  8. #8
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    my first step would be to clean your maf. The maf is used on start ups and wot. It sounds like that *could* be your issue. Wouldn't hurt to check fuel pressure too.

  9. #9
    Junior Member
    Join Date
    Jul 2007
    Location
    ohio
    Posts
    96

    silver
    99 Trans Am

    update:
    fuel filter changed. added a fuel system cleaner, (possible clogged injerctor?) going to change the oil and add a fuel stab. mob1 10w30 oil mob1 oil filter, lucus oil stab. and lucus fuel stab.

    didnt notice the problem but i only drove it for a few mins.
    i had a fuel pressure check. when key is on it is at 48. and they told me it should be at 55-60.. could that be the problem!??! i was told a 5psi change is enough to do that..... so could it be fuel pump? even though it runs fine?

  10. #10
    Junior Member
    Join Date
    Jul 2007
    Location
    ohio
    Posts
    96

    silver
    99 Trans Am

    how do i clean the maf sensor?

  11. #11
    Junior Member
    Join Date
    Jul 2007
    Location
    ohio
    Posts
    96

    silver
    99 Trans Am

    also, what pump should i buy i dont care what it is i want a quick and cheap fix i have guys calling to buy it and i cannot have a bad pump. so what lpm or whatever shuold i get? 150? 200? 250(which is like, high performance) what is the stock pump at? and any links to tell you how to change it yourself?

    and no ses light on and filter is clean

  12. #12
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    Quote Originally Posted by 99Trans_Am View Post
    how do i clean the maf sensor?
    just spray it with some CRC MAF cleaner.............sold at parts stores

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Car Stalling??????????
    By ptownboy420 in forum General Help
    Replies: 12
    Last Post: 07-17-2010, 09:06 AM
  2. Help: car stalling
    By 99yellowz28 in forum General Help
    Replies: 9
    Last Post: 04-25-2010, 02:04 PM
  3. Stalling
    By lsx camaro in forum Internal Engine
    Replies: 11
    Last Post: 07-10-2009, 02:19 PM
  4. Car stalling
    By paulc87 in forum General Help
    Replies: 3
    Last Post: 01-24-2008, 07:48 AM
  5. Z stalling out
    By 94redmaro in forum General Help
    Replies: 2
    Last Post: 05-30-2007, 03:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •