Page 2 of 2 FirstFirst 12
Results 21 to 25 of 25

Help!!! Motor burning oil?

This is a discussion on Help!!! Motor burning oil? within the General Help forums, part of the LSx Technical Help Section category; Originally Posted by YoMommasTA weird but i noticed the same exact thing.We were using 1 qt in 400 miles at ...

  1. #21
    Senior Member FasstChevys's Avatar
    Join Date
    Oct 2005
    Location
    Minnesota
    Posts
    3,315

    White
    '10 ZR1

    Quote Originally Posted by YoMommasTA View Post
    weird but i noticed the same exact thing.We were using 1 qt in 400 miles at times.I took the thing out and hammered the sheeet out of it for about 100 miles,now its using about 1 qt every 2-3k miles.By the way while hammering it i scared the piss outta myself on a 2-3 shift somewhere over the 100 mph mark,neat stuff.
    You've got that right on the 2-3 shift........try it after putting on a supercharger once.......the damn car gets all kinds of sideways just after the 1-2 shift!

  2. #22
    Impounded YoMommasTA's Avatar
    Join Date
    Jan 2006
    Location
    ne pa
    Posts
    532
    i almost lost it and put it into the guiderail,came home thinking if i had what i would say to my wife about her car.Hey honey i fixed the oil burning problem,but the engine is someplace along rt248 along with my shorts.Trouble with her car is she drives speed limits MAX and is a super slow driver.Her cars always go 200k,the bodies fall apart from rust and engine-trans are still running strong.
    Last edited by YoMommasTA; 11-01-2006 at 01:32 PM.

  3. #23
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Quote Originally Posted by KageSS View Post
    This is what you should do.

    Replace your POS original PCV valve with #12572717 updated fixed orifice type valve.

    http://www.mightyautoparts.com/pdf/articles/tt122.pdf

    That should help out alot on the burning oil situation.
    Good link. That pretty much explains the issue.

    I just stuck a breather filter on mine though, I can't stand having oil get sucked into the intake manifold.

  4. #24
    Senior Member FasstChevys's Avatar
    Join Date
    Oct 2005
    Location
    Minnesota
    Posts
    3,315

    White
    '10 ZR1

    Quote Originally Posted by YoMommasTA View Post
    i almost lost it and put it into the guiderail,came home thinking if i had what i would say to my wife about her car.Hey honey i fixed the oil burning problem,but the engine is someplace along rt248 along with my shorts.Trouble with her car is she drives speed limits MAX and is a super slow driver.Her cars always go 200k,the bodies fall apart from rust and engine-trans are still running strong.
    Nice!

  5. #25
    Member Jetblak's Avatar
    Join Date
    Sep 2006
    Location
    Willoughby,Ohio
    Age
    33
    Posts
    117

    Black on Black
    2000 Trans Am Ws6

    Thank you all very much and going to get it taken care of this winter!! Since its parked for the next 6 months, cant wait till spring

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •