Page 7 of 7 FirstFirst ... 34567
Results 121 to 123 of 123
Like Tree1Likes

Help!! !i may have hydrolocked engine after head install!!!

This is a discussion on Help!! !i may have hydrolocked engine after head install!!! within the General Help forums, part of the LSx Technical Help Section category; I also noticed that the oil I drained had a grey watery tent to it.....just like the oil that was ...

  1. #121
    Member jb3golf's Avatar
    Join Date
    Jan 2007
    Location
    Zona
    Posts
    600

    Red
    1998 Camaro Z28 Conv. M6

    I also noticed that the oil I drained had a grey watery tent to it.....just like the oil that was in my crankcase that I thought may be coolant..(from my earlier post). Also that oil had a slight smell of gas to it........

  2. #122
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Any pics?

  3. #123
    Member jb3golf's Avatar
    Join Date
    Jan 2007
    Location
    Zona
    Posts
    600

    Red
    1998 Camaro Z28 Conv. M6

    A quick update........I got the map sensor issue fixed and no more P0107 code, but the car still pops, misfires and will barely start......still can't believe major engine damage could occur from excessive cranking/starting though......this is a weird nightmare guys......

Page 7 of 7 FirstFirst ... 34567

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hydrolocked from melting snow??????
    By Z28dryva in forum Internal Engine
    Replies: 18
    Last Post: 04-24-2013, 09:13 AM
  2. Question: Anyone HYDROLOCKED there LS1 F-BODY?
    By nillam1 in forum External Engine
    Replies: 56
    Last Post: 05-24-2010, 11:05 PM
  3. Engine Ticking After Head and Cam Install
    By Eddie 70 in forum Internal Engine
    Replies: 13
    Last Post: 01-28-2008, 05:50 PM
  4. Stock Head Unit System or install custom head unit?
    By ibh182 in forum Stereo and Electronics
    Replies: 3
    Last Post: 06-16-2007, 10:43 AM
  5. Engine noise after Head/Cam install
    By LOWnMEAN in forum Internal Engine
    Replies: 7
    Last Post: 03-14-2006, 12:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •