Results 1 to 5 of 5

Help gauge problem and cannot connect to dlc

This is a discussion on Help gauge problem and cannot connect to dlc within the General Help forums, part of the LSx Technical Help Section category; hey i have a 99 trans am i had wrecked it and am almost finished re building it the car ...

  1. #1
    Junior Member ls1racer1999's Avatar
    Join Date
    Jun 2009
    Location
    nj
    Posts
    10

    white
    1999 trans am

    Help gauge problem and cannot connect to dlc

    hey i have a 99 trans am i had wrecked it and am almost finished re building it the car has been running no problems for months now then suddenly one day i park it then the next afternoon after work the car will start up run ok at idle then the fuel gauge cuts out and the coolant temp gauge and the tach and i cannot connect my laptop to it ive tested wires and fuses and grounds i replaced the the pcm pcm was programmed for some reason theres no signal from the dark green wire pin 58 on the blue connector and im not sure what controls that circut and everything . but still the same problem im stumped and its very frustrating dose anyone have any ideas please? thanks

  2. #2
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    San Jose
    Age
    36
    Posts
    1,897

    Red
    1998 Pontiac Trans Am

    Pin 58 is for the Serial data to the DLC. That's why you can't talk to the car. It goes to a ground splice. Follow the wire to the splice and make sure it's still intact

  3. #3
    Junior Member ls1racer1999's Avatar
    Join Date
    Jun 2009
    Location
    nj
    Posts
    10

    white
    1999 trans am

    ok ill check it out i had done a continuity test from pin 58 to the DLC it it showed good or am i missing something?. is it possible that the pcm talks to the logic in the cluster asm and could the cluster asm be bad and not sending information out to the pcm from those gauges? if i let the car sit for a few days then try it it will work for about 2-5 min then cuts out and wont work again untill i let it sit for a few more days almost as if somethings heating up and cutting out its doing it with the new pcm 2 so i kinda ruled them out when this happens the car still will start and run just not very good it has a slight pop in the exhaust and just sounds like a miss
    Last edited by ls1racer1999; 11-09-2009 at 03:14 PM.

  4. #4
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    San Jose
    Age
    36
    Posts
    1,897

    Red
    1998 Pontiac Trans Am

    here's a diagram I hope it helps you out


  5. #5
    Junior Member ls1racer1999's Avatar
    Join Date
    Jun 2009
    Location
    nj
    Posts
    10

    white
    1999 trans am

    ok cool thanks alot

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Ls swap gauge problem
    By 95chevy in forum GM Trucks
    Replies: 1
    Last Post: 07-16-2016, 01:07 PM
  2. Question: How to connect air/fuel ratio gauge?
    By Cali Night Stalker in forum General Help
    Replies: 37
    Last Post: 08-10-2009, 05:24 AM
  3. Fuel Gauge Problem???
    By peterlawl84 in forum General Help
    Replies: 9
    Last Post: 04-05-2009, 09:54 PM
  4. Oil pressure issue/ gauge problem
    By Justin93 in forum Internal Engine
    Replies: 7
    Last Post: 12-18-2008, 06:49 PM
  5. Gas Tank/Gauge problem.
    By 95Fyrebyrd in forum General Help
    Replies: 1
    Last Post: 03-04-2008, 06:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •