Results 1 to 6 of 6

Help Fan Problem!!

This is a discussion on Help Fan Problem!! within the General Help forums, part of the LSx Technical Help Section category; when the car is turned off, sometimes the fan continues to run, sometimes lasting for a couple hours. I have ...

  1. #1
    Member
    Join Date
    Jul 2006
    Location
    oceanside ca
    Posts
    943

    Red
    06 GTO

    Unhappy Help Fan Problem!!

    when the car is turned off, sometimes the fan continues to run, sometimes lasting for a couple hours. I have checked the connections and there doesnt seem to be any loose wires or anything. I have pulled the fuse and it shuts the fan off (odviously) but when i put it back in the fan continues running. If anybody can help please let me know.

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Don't know what's going on but definitely not normal. LS1's will keep the fans on after shut off if the PCM sees it overheating (284*) but for only for 3 or 4 minutes - with the stock tune. Any SES codes, aftermarket fan switch/mods, etc? Two hours is way too long in any case IMO. Sorry don't have a definitive answer...TTT for you.

  3. #3
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    588

    Black
    2000 Camaro SS Conv.

    There are three fan relays, energized by the PCM. As a first step you might try resetting the PCM. My next guess without a voltage tester etc. is that one of the relays is hanging.

  4. #4
    Member
    Join Date
    Jul 2006
    Location
    oceanside ca
    Posts
    943

    Red
    06 GTO

    thanks guys, i am going to try replacing the tstat, then i am going to check the relays and other things like that.

  5. #5
    Junior Member
    Join Date
    Jan 2007
    Location
    Glendale az
    Age
    30
    Posts
    74
    if it's really staying on for 2 hours, I'd look more towards the relay than I would the t-stat. although it probably wouldn't hurt to replace it anyway just for maintenance sake if you haven't done it in awhile.

  6. #6
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    588

    Black
    2000 Camaro SS Conv.

    I can't find documentation on how long the PCM will energize the relays but I can't imagaine it would be more than 5 minutes no matter what the temp was. Once you shut the engine off the stat is immaterial since the coolant is not flowing anyway. Can't tell yet what the problem is but 99.9% it is not the stat.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •