Results 1 to 5 of 5

HELP! Cooling problem in Vegas after STS install.

This is a discussion on HELP! Cooling problem in Vegas after STS install. within the General Help forums, part of the LSx Technical Help Section category; Ok, here's the deal. I put an STS rear mount on the car and have a front mount intercooler. I ...

  1. #1
    Junior Member Alaska SS's Avatar
    Join Date
    Jul 2006
    Location
    Anchorage, Alaska
    Age
    45
    Posts
    30

    Black
    2002 Camaro SS

    HELP! Cooling problem in Vegas after STS install.

    Ok, here's the deal. I put an STS rear mount on the car and have a front mount intercooler. I live in Vegas and it's 100-115 every day. The car stays at 210 degrees all the time. In traffic if sitting at lights for a while the car will creep to 220ish. Once it's there it's just a matter of time and it pegs the temp guage and spits coolent everywhere. This is under normal driving conditions without boosting the car at all. We thought it was the 160 degree thermostat we put it but we swapped it for the stock and the car still does it. We checked the relays for the fans and they are staying on. Our guess now is we have a bad fan/fans and they are shutting off or slowing down for some reason when the car gets to 225-227 degrees. Any ideas????? Also, if you think it is the fans should I replace then with OEM or is there an aftermarket that is better? Just a little more FYI, there are no other F-Bodys in town with cooling problems and there are several rear mount turbo cars with front mount intercoolers and they also have no problems. HELP...PLEASE!!! Thanks all.

  2. #2
    down with the lot lizards blackhawk01's Avatar
    Join Date
    Dec 2006
    Location
    Pensacola
    Age
    27
    Posts
    1,565

    Red
    2001 Camaro SS A4

    I know it sounds like a bitch but check your water pump

  3. #3
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    Start simple....check for a dirty/blocked radiator or even the condensor. Check for a collapsed hose...have you back flushed the system lately? What temp do you have your low/high fans programmed to come on at?

  4. #4
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    I am assuming that you had the fans reprogrammed to come on at a lower temp?

  5. #5
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    68
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Quote Originally Posted by SeVeReDiStOrTiOn View Post
    Start simple....check for a dirty/blocked radiator or even the condensor. Check for a collapsed hose...have you back flushed the system lately? What temp do you have your low/high fans programmed to come on at?
    Man I had a hose that was bad on the inside once.

    When the car heated up the damned wall would collapse inside & block the flow. Couldn't tell from looking at it......found it by squeezing the hoses & found a soft spot by chance.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Install price of STS Turbo?
    By 95TA383 in forum Forced Induction
    Replies: 2
    Last Post: 05-27-2006, 02:43 PM
  2. Problem with new clutch install, need help
    By FuriousGeorge in forum Manual Transmission
    Replies: 0
    Last Post: 04-27-2006, 06:17 AM
  3. 92 Camaro RS Transmission Install Problem
    By Bigrob92rs in forum Camaro / SS
    Replies: 0
    Last Post: 04-06-2006, 04:32 PM
  4. STS problem solved..sort of
    By kllrvet in forum Forced Induction
    Replies: 0
    Last Post: 03-18-2006, 07:25 PM
  5. big problem with header install...NEED HELP FAST!!!
    By groundpoundinlt1 in forum General Help
    Replies: 20
    Last Post: 02-12-2006, 04:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •