Results 1 to 11 of 11

Help! Changed coolant now overheating??

This is a discussion on Help! Changed coolant now overheating?? within the General Help forums, part of the LSx Technical Help Section category; Hey guys, I'm from Australia, and I'm wondering if anyone can help me out? I've got an '05 LS1, and ...

  1. #1
    Junior Member
    Join Date
    Apr 2006
    Location
    Oz
    Age
    35
    Posts
    2

    Help! Changed coolant now overheating??

    Hey guys,

    I'm from Australia, and I'm wondering if anyone can help me out? I've got an '05 LS1, and I just drained the coolant out, flushed the system and refilled it....now the motors overheating! Cant fit anymore coolant in it if I tried. Any ideas?

    Any help would be much appreciated.

    Cheers,
    Scott (AUS)

  2. #2
    Yeah baby! Yeah! silverWS6's Avatar
    Join Date
    May 2009
    Location
    okc
    Posts
    2,571

    Silver 2002 WS.6
    Red 1989 Formula

    Air in the system?

  3. #3
    Junior Member
    Join Date
    Apr 2006
    Location
    Oz
    Age
    35
    Posts
    2
    I thought it might be. How do I fix it though?

  4. #4
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    This may be a stupid question....but how much coolant did you put in?
    Did you add more after the thermostat opened up?

    Otherwise, I would guess air in the system as well. Some vehicles have a bleeder on the coolant lines somewhere.

  5. #5
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    +1 for air in the cooling system.

    SteveC

  6. #6
    Yeah baby! Yeah! silverWS6's Avatar
    Join Date
    May 2009
    Location
    okc
    Posts
    2,571

    Silver 2002 WS.6
    Red 1989 Formula

    What about running it with the radiator cap off and add coolant till its full......?

  7. #7
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    Have you figured out what the problem was?

    SteveC

  8. #8
    Impounded
    Join Date
    Apr 2006
    Location
    park bench
    Posts
    1,399
    gmcheviac

    Quote Originally Posted by silverWS.6 View Post
    What about running it with the radiator cap off and add coolant till its full......?
    That's what I do with my truck, run it a couple of minutes and refill as the bubbles bleed. Not sure about how it works with the external tanks now though. It should have a bleed in the system. Some vehicles won't let air through the thermostat so there is a place to bleed them there

  9. #9
    BLKHWK Durango's Avatar
    Join Date
    Oct 2008
    Location
    New Brunswick Canada
    Age
    47
    Posts
    881

    Black
    BLK TA modded 12.2@113mph

    yep

    take the rad cap off let iut run until it stops bubbling and add to fill it might take 20 minutes or so

    Good luck

  10. #10
    Awaiting Activation
    Join Date
    Oct 2007
    Location
    NC
    Posts
    635

    SOM
    1998 T.A.

    Sometimes I squeeze the upper hose to help "burp" the system.

  11. #11
    Member zeetwentyeight's Avatar
    Join Date
    Aug 2009
    Location
    A, A
    Age
    27
    Posts
    690

    Red
    1998 Camaro Z28

    Crank the defrost as you are running it with the rad cap off and keep adding for about 10 min

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Need pic of coolant pump weep hole (Coolant Leak)
    By Sweet Chops in forum General Help
    Replies: 13
    Last Post: 04-20-2009, 08:14 PM
  2. Replies: 23
    Last Post: 06-19-2007, 08:28 AM
  3. Coolant light...coolant level full.
    By SR71 in forum General Help
    Replies: 4
    Last Post: 01-08-2007, 10:35 AM
  4. coolant light on, full on coolant
    By Brownboy2020 in forum Firebird / WS6
    Replies: 10
    Last Post: 08-10-2006, 01:26 PM
  5. ls6 intake coolant plugs or extra front coolant pipe?
    By mikes ss in forum External Engine
    Replies: 3
    Last Post: 12-03-2005, 05:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •