Results 1 to 5 of 5

help

This is a discussion on help within the General Help forums, part of the LSx Technical Help Section category; hey fellows was wanting input i have a 99 ss with 89,000 miles mods in sig only sprayed a couple ...

  1. #1
    Junior Member leviathon 88's Avatar
    Join Date
    Mar 2007
    Location
    califonia
    Posts
    44

    blue
    99 camaro ss

    Exclamation help

    hey fellows was wanting input i have a 99 ss with 89,000 miles mods in sig only sprayed a couple of times i have posted about this topic a couple of times and haven't yet resolved the issue i am having a problem with hesitation of my car while in gear along with a random high idle while my foot isn't depressing the throtle it will stick (not the acccelorator the engine rpm) at around 1600-1700rpm at idle. when i am in gear i feel a loss in performance do to hesitation unless im above 5000rpm do i get a stroong throtle response whatsover it sometimes rattles quite violently in 6th gear while cruising on the highway to point were i downshift to 5th out of fear of damaging the gearbox. to elaborate more the engine from 2000 to about 4000 rpms shrugs and makes gurgaling noise coming from the engine while under wot, i sounds as if its flooding i innitially thought it to be a plug or ignition wire gone bad, but i am not quite confident in this issue i have spent hours and hours reaserching this and posting here and the most assuring feedback i recieved was to use seafoam as a quick check and if thats not it move onto plugs and wires, then check the pcm and all other possibiliities i am no mechanic, but with seafoam do you think this could be a succesful route and when applying it to the throtle body throat were is that excatly on the car picture would help assuming after the gardinely box after the lid? and also how do i puor it into the oil case crank? like isaid a picuture would help. any input would help here is alink to the site and it describes how to apply the product, all i need is help with the throtle body aplication and the oil crank case . http://www.seafoamsales.com/motorTuneUpTechGas.htm
    [COLOR="Red"]410 rwhp, 407rwtq h/c/i ls1-edit, not cats, magniflow with ory, m6.
    100 dry shot nos not dynoed yet with ]

  2. #2
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    honestly i think i had the same problems on my winter car.

    If your easy on the gas till rpm is reach then shift,( its fine) right?

    but if your hard on the gas it seems like rpms wont reach and sputters.

    my guess is honeslty is the plugs. same symptons and did wonders. i alsmost called a car donation company untill i tried this

  3. #3
    Junior Member leviathon 88's Avatar
    Join Date
    Mar 2007
    Location
    califonia
    Posts
    44

    blue
    99 camaro ss

    exactly the case uuh and i went out and bought the seafoam ohh well only 6 bucks, did you notice the power loss as well and was it just your plugs or was it the ignition wires too that went bad

  4. #4
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    it was just the plugs. the cheapest 15 $ fix i ever did.

    and there was huge power loss took soo long to get to highways speeds

  5. #5
    Senior Member greatwhiteZ28's Avatar
    Join Date
    Nov 2006
    Location
    d
    Age
    33
    Posts
    3,675

    white
    2002 z28

    the next week i also added some plugs wires just to be safe but my problem was just the plugs

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •