Results 1 to 7 of 7

Help!!!

This is a discussion on Help!!! within the General Help forums, part of the LSx Technical Help Section category; I tried to remove the over lay on a 99 Camaro...and now none of the gauges will work...I followed the ...

  1. #1
    Senior Member Blown Interceptor's Avatar
    Join Date
    Jul 2000
    Location
    San Diego, Ca
    Posts
    1,849

    Black
    1999 Camaro SS

    Help!!!

    I tried to remove the over lay on a 99 Camaro...and now none of the gauges will work...I followed the instructions, but to no avail.


    Can anyone help me to fix this disaster? the fuel and temp are maxed out along with the RPM gauge, and the MPH gauge is reading zero...


    Anyone?


    Thanks,
    Jason

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Ouch. I haven't messed with ours, so no clue on how that project is done. Good luck!

  3. #3
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by pajeff02 View Post
    Ouch. I haven't messed with ours, so no clue on how that project is done. Good luck!
    I don't even know what "removing the overlay" means

  4. #4
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    I hope you didn't remove any of the needles... post up what all you did...

  5. #5
    Senior Member Blown Interceptor's Avatar
    Join Date
    Jul 2000
    Location
    San Diego, Ca
    Posts
    1,849

    Black
    1999 Camaro SS

    Yes I did. That happened to be the problem...but the issue is fixed.
    1999 Black Camaro SS

    Lid, Fast Toys, 3.90's, N20

    More to come!!!!

  6. #6
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    Sup Jason;

    When did you get out of jail?

    Did you post bail?

    Great to see you back

    SteveC

  7. #7
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    OP - what was the problem and how did you fix it?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •