Results 1 to 5 of 5

Help....

This is a discussion on Help.... within the General Help forums, part of the LSx Technical Help Section category; Ok, I have a 2000 WS6, it just turned 40,xxx miles, i am the only owner of the car, it ...

  1. #1
    Member screamin chicken's Avatar
    Join Date
    Jul 2005
    Location
    sc
    Age
    48
    Posts
    517

    Black, Red, Silver Jade
    00 WS6,95 Ta, 69 R code

    Help....

    Ok, I have a 2000 WS6, it just turned 40,xxx miles, i am the only owner of the car, it sits in the garage, i do have a ton of mods on it, but this shouldn't be the issue. Three times this year , middle of the summer, and just last week, I noticed after i drove it from the passenger side running down to the front of my car, I assume because that's the low spot towards the garage door my coolant has drained out.The last time the radiator was completely empty, i haven't checked it yet. I guess after i turn it off its running out of the over flow ???? but why would this happen... Thanks

  2. #2
    Junior Member lownloud99's Avatar
    Join Date
    Dec 2013
    Location
    Bethany, OK
    Posts
    29

    white
    99 Z28

    Are you overheating any prior to the leak?
    99' WS6- Victory Red with T-Tops, BMR LCA's, Sub-frame Connectors, UMI STB, BMR Torque Arm, and Shift Kit

  3. #3
    Member screamin chicken's Avatar
    Join Date
    Jul 2005
    Location
    sc
    Age
    48
    Posts
    517

    Black, Red, Silver Jade
    00 WS6,95 Ta, 69 R code

    no over heating, gauge is where its always been

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    check the drain plug? make sure not cracked? Same goes for the sensor that is located IIRC on that side.

    have you done a pressure check yet?

    Something might have bounced up and damage the radiator...

  5. #5
    Member screamin chicken's Avatar
    Join Date
    Jul 2005
    Location
    sc
    Age
    48
    Posts
    517

    Black, Red, Silver Jade
    00 WS6,95 Ta, 69 R code

    No pressure test, but i will check the drain. I do not drive it often i actually just turned 40,xxx on it, but it is highly modded and dropped 2 in, and when i pull out of the drive way it does scrape the flap under the car... Thanks i will have to look under there....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •