Page 2 of 2 FirstFirst 12
Results 21 to 25 of 25

Heavy backfire when under a load

This is a discussion on Heavy backfire when under a load within the General Help forums, part of the LSx Technical Help Section category; Yeah with a cam and cutout, you might be stuck with some backfiring, but if its REALLY REALLY bad...there's probably ...

  1. #21
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Yeah with a cam and cutout, you might be stuck with some backfiring, but if its REALLY REALLY bad...there's probably something wrong. there are other possiblities for backfire including valvetrain and ignition system issues.

  2. #22
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    yeah i like it at night when you can see it but mine isnt bad. I think its kinda cool lol

  3. #23
    Member derekbuckner1's Avatar
    Join Date
    Oct 2009
    Location
    West Virginia
    Posts
    451

    LPM
    2000 Z28

    I think everyone here is talking about two different things. Everyone (mostly) loves the growl and gurgle of a ls motor when you get out of the throttle. On the other hand, if it's a consistent actual backfire, not the steady growl... There is a problem. I'm only saying this because you said you can see it at night. If you are throwing flames through your cutout consistently, get it checked out. Mine is loud on decel with the cutout open, but I am yet to see a flash.

    LS6 Intake, LS6 VCT, E^2 Catch Can, Hooker LTs and ORY, Magnaflow Cat-Back, 3" QTP electric cutout, UMI adj LCA, PHB, 3 pt SFCs, STB, MGW Shifter, SLP lid and bellow, Free-Mods, Tuned by BlueCat


  4. #24
    Senior Member Lunatikgixxer's Avatar
    Join Date
    Mar 2010
    Location
    St Pete, FL
    Posts
    1,429

    Bat mobile black
    2000 Trans am WS6 M6

    ok.. when im accelerating and shift at 6k rpms it backfires one time, Boom, shoots a flame (i think (what a friend told me)), and i continue on accelerating.. Thats my situation. If it was constant it definitely be bad.

  5. #25
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    To me, any unburnt fuel escaping through the exhaust port and being burnt off in the exhaust = loss of power.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. white smoke under heavy load OPINIONS??
    By rovadenko in forum General Help
    Replies: 8
    Last Post: 09-04-2009, 09:19 PM
  2. Backfire
    By 98warbird in forum General Help
    Replies: 1
    Last Post: 12-22-2008, 04:41 PM
  3. Question: !!!!backfire!!!
    By pmolina0436 in forum GTO
    Replies: 20
    Last Post: 09-27-2008, 09:15 PM
  4. backfire 6.0 bad
    By whitez28onspray in forum Internal Engine
    Replies: 4
    Last Post: 02-07-2007, 03:55 PM
  5. Backfire
    By feet739 in forum Internal Engine
    Replies: 10
    Last Post: 09-21-2006, 06:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •