Results 1 to 3 of 3

Having problems with my PS pump pulley

This is a discussion on Having problems with my PS pump pulley within the General Help forums, part of the LSx Technical Help Section category; One of my lifters collapsed in my Camaro. I had to remove my power steering pump and pulley to remove ...

  1. #1
    Junior Member
    Join Date
    Apr 2013
    Location
    Houston
    Posts
    1

    Having problems with my PS pump pulley

    One of my lifters collapsed in my Camaro. I had to remove my power steering pump and pulley to remove my cyl head. i used a tool that i rented from O'Reilly's and was able to remove the pulley with no problem what so ever, but now the damn thing won't go back on. the removal tool set that I rented doesn't have the correct part to reinstall the pulley. took it back to O'Reilly's but they didn't know what to make of it. ended up using a 22mm socket and brass hammer to "gently" reinstall the pulley. its in most of the way. I used my electronic caliper and i still have almost 0.200" until my pulley is fully seated. Can it be left the way it is or would it put extra unwanted side ways tension on the belt? if it cannot be left the way it is then how do i get it in the rest of the way?

  2. #2
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    You must seat the pulley all the way for proper belt alignment. Go to a service center which has a hydraulic press and have them seat it for you.
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

  3. #3
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    I had the same exact problem last time I removed that pulley, it ended up stripping the threads, had to get a new pump.

    Look at the treads of the pump see if they are messed up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PS Pump Problems
    By chris1974 in forum External Engine
    Replies: 6
    Last Post: 05-04-2012, 01:50 PM
  2. Power Steering Pump Pulley
    By AFASTYZFR1 in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 09-21-2008, 02:57 PM
  3. WTB F-body power steering pump pulley
    By 76ls1bird in forum Parts Wanted / Trade
    Replies: 1
    Last Post: 09-19-2007, 12:52 PM
  4. I Need A Powersteering Pump Pulley
    By Chris2001SS in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 09-16-2006, 07:19 AM
  5. UD Pulley M6 Problems?
    By sdbrown84 in forum External Engine
    Replies: 5
    Last Post: 05-20-2006, 12:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •