Results 1 to 12 of 12

Have I killed my motor? Please help me save her!

This is a discussion on Have I killed my motor? Please help me save her! within the General Help forums, part of the LSx Technical Help Section category; Hey everyone, I have come into alittle money and decided to fix up my 1999 Camaro SS. I dont know ...

  1. #1
    Junior Member
    Join Date
    Feb 2009
    Location
    KY
    Posts
    55

    Black
    1999

    Have I killed my motor? Please help me save her!

    Hey everyone, I have come into alittle money and decided to fix up my 1999 Camaro SS. I dont know much about cars at all. So I started by checking the oil when I discovered that there was rust on the dip stick. Also there was rust on the inside of the oil cap and down in the oil line. When I checked the coolant there was a dried up flaky coolant substance on the coolant dip stick. My ? is have I killed my motor? Any info or opinions you have will be very helpful. Thank you for your time, sincerly Nick.

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    what does the actual coolant look like? Take the cap off and look at it. What you're seeing could just be coincidental. Condensation can make the oil cap look like that. Has the car been sitting or started for short periods of time lately? Also, dexcool will get a funky look to it. Could all be normal. If your coolant in the radiator looks like a chocolate milk shake then you have problems. Blown head gasket or busted oil cooler line or something.

  3. #3
    NY Representative basballny2's Avatar
    Join Date
    Aug 2007
    Location
    NeW YoRk
    Posts
    3,393

    Red
    2001 ws6

    change the oil and coolant and start her up haha

  4. #4
    Junior Member slp1122's Avatar
    Join Date
    Nov 2008
    Location
    oc/las vegas
    Posts
    79

    pewter
    2000 camaro ss

    it's not rust, don't worry it's just the way the dirty oil looks. coolant gets like the way you described. change it and the oil and you should be good to go.

  5. #5
    Millennium Falcon mpfranks's Avatar
    Join Date
    Sep 2007
    Location
    Akron, Oh
    Posts
    689

    Red
    2000 Trans Am WS.6

    take it to someone who know what theyre doing before you do kill her

  6. #6
    You want MuShu? Soul TKR's Avatar
    Join Date
    Aug 2005
    Location
    Murrieta, CA
    Age
    35
    Posts
    441

    Arctic White
    1999 WS.6 Trans Am


  7. #7
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Where are you from in KY? Ill help if your within... 50-75ish miles?

    I know plenty of people that wouldnt mind helping you as well from all over KY

    Post up

  8. #8
    Junior Member
    Join Date
    Feb 2009
    Location
    KY
    Posts
    55

    Black
    1999

    Thanks everyone for the help. I changed the oil and antifreeze. After that no problems. Drove about 150 miles. Joshiedoom, I live in Pikeville.

  9. #9
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Quote Originally Posted by COKEBOTTLES View Post
    Thanks everyone for the help. I changed the oil and antifreeze. After that no problems. Drove about 150 miles. Joshiedoom, I live in Pikeville.
    Damn otherside of the country. lol

  10. #10
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    One of the sponsors here KY Speed is out of Pikeville I believe.

  11. #11
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Quote Originally Posted by 0rion View Post
    One of the sponsors here KY Speed is out of Pikeville I believe.
    I do think Mark is... I think

  12. #12
    Junior Member slp1122's Avatar
    Join Date
    Nov 2008
    Location
    oc/las vegas
    Posts
    79

    pewter
    2000 camaro ss

    Quote Originally Posted by COKEBOTTLES View Post
    Thanks everyone for the help. I changed the oil and antifreeze. After that no problems. Drove about 150 miles. Joshiedoom, I live in Pikeville.
    good to hear. make sure you check the oil and other fluids every week or two and stay on top of things. seems like you're in good shape now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Save ls1.com!
    By blackbird0230 in forum Almost Anything Goes
    Replies: 18
    Last Post: 04-02-2013, 04:54 PM
  2. How would you save gas?
    By 02ultraZ in forum Almost Anything Goes
    Replies: 80
    Last Post: 12-30-2007, 04:02 PM
  3. Something funny happened, then got killed and killed today !
    By Speedy_Gonzales in forum Kill Stories
    Replies: 3
    Last Post: 10-17-2007, 08:39 PM
  4. Killed a 600 bike with the new motor
    By cam02ss in forum Kill Stories
    Replies: 51
    Last Post: 06-11-2007, 06:23 AM
  5. Replies: 15
    Last Post: 03-23-2006, 10:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •