Results 1 to 6 of 6

got the codes

This is a discussion on got the codes within the General Help forums, part of the LSx Technical Help Section category; Hey guys, a while back i made a thread about my SES light comming on. Well today i called a ...

  1. #1
    Senior Member rajiv1998's Avatar
    Join Date
    Sep 2006
    Location
    New Jersey
    Age
    30
    Posts
    1,489

    Black
    1998 Pontiac Trans Am

    got the codes

    Hey guys, a while back i made a thread about my SES light comming on. Well today i called a friend to come over and we decided to check out what was wrong. We did the diagnostic test and 2 codes came up. P0430 "Catalyst efficiany below threshold bacnk 2." Now I know for a fact that the cat is fine becasue i had it checked out and every1 said it wasnt bad. I also replaced my 02 sensors about 2 months back, so i know for a fact its not that. I just dont know wut the fuck it is, and its driving me nuts to see that dam SES light on. The next code was P0300 "Random missfire." I dont know what this is either. Its seems to be running on all 8 cylinders and i double checked my plugs, wires and coilpacks. Everything is on nice and tight. From what i hear i am comming to the conclusion there MIGHT be an aftermarket cam in the car? Its choppy during startup and has a little bit of a rough idle, however this can be from the missfire. Any1 have any suggestions? The car runs strong with no hesitation when u step on the gass, and all the guages and fluids are fine, oil has been changed every 3k miles with moble 1, so im kinda lost.

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Visit gearchatter.com and look up the code descriptions/diagnostics for your year if you haven't done so already. P0430 is almost always the cat if the rear 02 and wiring is fine. You could also swap the rear 02's from bank to bank, clear all codes, and see if it throws P0420 for the drivers side.

  3. #3
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Just because you bought an 02 sensor two months ago, doesn't mean it hasn't already taken a shit on you. I would not be surprised if your 02 is bad, especially if you bought a Bosch replacement 02.
    CCW SP 500s 18x10 275/35 18x11 295/35
    SLP CME with GMMG style catback
    Painted manta stripe

    Quote Originally Posted by konigandy6 View Post
    I'd rather be bi than full homo!!!!

  4. #4
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    switching it is the easiest way to tell if the sensor is bad, if the code follows it then that's your culprit but I would question why it's bad after only 2 months. Also, how do you check a cat out? Who told you it was fine? My money is on a bad cat.

  5. #5
    Quote Originally Posted by rajiv1998 View Post
    Now I know for a fact that the cat is fine becasue i had it checked out and every1 said it wasnt bad.
    Who is "everyone" and how did they verify that the cat wasn't bad? It is very possible for a catalytic converter to fail due to inefficiency and not affect engine performance at all. A catalyst inefficiency code is caused from a failed converter 99.9% of the time. A failed rear O2 will NOT cause a catalyst DTC regardless of what anyone tells you. The P0300 DTC could be LOTS of things. Could even be your catalytic converter... What plugs do you have in the car?

  6. #6
    Senior Member rajiv1998's Avatar
    Join Date
    Sep 2006
    Location
    New Jersey
    Age
    30
    Posts
    1,489

    Black
    1998 Pontiac Trans Am

    Well now the car is misfiring. It will jerk and shake when u try and get it moving from a dead stop. It will hesitate for a second the run fine. It runs great under WOT and doesnt do anything above 3k. I dont know wtf is wrong and im pulling my hair out trying to find out. Those are the only 2 codes that show up. The missfire thing is driving me crazy becasue the car just jerks and shakes. I checked my plugs and wires and they seem to be fine so idk wut it is. Any1 have any advice?? And the plugs i have are NGK TR555-IX with the MSD 8.5 super conductor race wires.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what do these codes mean
    By jb007 in forum General Help
    Replies: 0
    Last Post: 05-19-2010, 07:32 PM
  2. codes
    By camaro00ss in forum General Help
    Replies: 5
    Last Post: 03-31-2008, 11:14 AM
  3. no RPO codes
    By deepblackz in forum Camaro / SS
    Replies: 4
    Last Post: 11-06-2007, 08:56 AM
  4. What do these codes mean. PLEASE HELP
    By ram air ws6 in forum General Help
    Replies: 5
    Last Post: 02-23-2007, 06:34 PM
  5. New and I need some help with SES codes.
    By mczerwonka in forum General Help
    Replies: 3
    Last Post: 01-28-2007, 08:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •