Results 1 to 8 of 8

got bad piston slap.. Which oil??

This is a discussion on got bad piston slap.. Which oil?? within the General Help forums, part of the LSx Technical Help Section category; Im using royal purple 10W30 right now.. what do u guys think is the "best" oil ?? I was going ...

  1. #1
    rice..a growing epidemic PAT-LS101's Avatar
    Join Date
    Dec 2006
    Location
    OREGON
    Posts
    212

    blue
    2002 camaro z28 a4

    got bad piston slap.. Which oil??

    Im using royal purple 10W30 right now.. what do u guys think is the "best" oil ?? I was going to try Mobil 1 30W??

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Why 10w 30? How many miles do you have on the car?
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    I run 10w-30 in both of our SS's. One has had piston slap forever and the other doesn't have the slightest hint of it.
    Luck of the draw I guess, but I can tell you I run the same oil in both so I'd venture to say the oil I'm running has nothing to do with it.

    I have heard of people switching from synthetic to regular dino oil (same weight) and the slap is less noticable. Not sure why, I've never tried it myself.

  4. #4
    rice..a growing epidemic PAT-LS101's Avatar
    Join Date
    Dec 2006
    Location
    OREGON
    Posts
    212

    blue
    2002 camaro z28 a4

    Quote Originally Posted by Firebirdjones View Post
    I run 10w-30 in both of our SS's. One has had piston slap forever and the other doesn't have the slightest hint of it.
    Luck of the draw I guess, but I can tell you I run the same oil in both so I'd venture to say the oil I'm running has nothing to do with it.

    I have heard of people switching from synthetic to regular dino oil (same weight) and the slap is less noticable. Not sure why, I've never tried it myself.
    Yeah.. I have it pretty bad when it starts up sounds like its going to fall apart but goes away and running for a bit....

  5. #5
    Member
    Join Date
    Nov 2008
    Location
    harrisburg pa.
    Age
    61
    Posts
    868

    black
    02 vette vert

    Quote Originally Posted by Firebirdjones View Post
    I run 10w-30 in both of our SS's. One has had piston slap forever and the other doesn't have the slightest hint of it.
    Luck of the draw I guess, but I can tell you I run the same oil in both so I'd venture to say the oil I'm running has nothing to do with it.

    I have heard of people switching from synthetic to regular dino oil (same weight) and the slap is less noticable. Not sure why, I've never tried it myself.
    i dont know if i buy that oil makes any diff in the piston slap. when i bought this car w/1111,000 it had it, changed oil w/10/30 dino, then couple hundred miles later w/5/30 castrol edge syn., and the noise never changed. its not a condition like noisy bearings or lifters at cold start where oil could make a difference imo. the type of condition that exists which causes the noise is totally different. the ambient temp does seem to play a part in the severity and duration of the piston noise though, which makes sense.

  6. #6
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by dklowrider View Post
    i dont know if i buy that oil makes any diff in the piston slap. when i bought this car w/1111,000 it had it, changed oil w/10/30 dino, then couple hundred miles later w/5/30 castrol edge syn., and the noise never changed. its not a condition like noisy bearings or lifters at cold start where oil could make a difference imo. the type of condition that exists which causes the noise is totally different. the ambient temp does seem to play a part in the severity and duration of the piston noise though, which makes sense.
    Just stating what I've been told. Never tried switching myself since I have a pair of 4th gens and only one is doing it. Both use the same oil
    Just one of the evils of an LS motor. Pretty common actually.
    Last edited by Firebirdjones; 03-29-2009 at 05:49 PM.

  7. #7
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by PAT-LS101 View Post
    Yeah.. I have it pretty bad when it starts up sounds like its going to fall apart but goes away and running for a bit....
    Mine does it cold. After running for a few miles it goes away so I just don't worry about it.

    Now if it drops a piston skirt in the pan I might have to do something about it
    Honestly I just look at it as a reason to buy a crate motor in the future if it gets to that point.

  8. #8
    38 of 139 PontiacFan's Avatar
    Join Date
    Jul 2005
    Location
    Kearney, NE
    Posts
    931

    Black
    2001 Pontiac

    Search 'German Castrol'.
    People swear by it, reducing noise, ...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Piston Slap?
    By 1999sscamaro in forum Internal Engine
    Replies: 15
    Last Post: 01-20-2011, 06:33 AM
  2. Piston Slap + Cam = ?
    By WS6ICK2K in forum Internal Engine
    Replies: 0
    Last Post: 05-05-2008, 08:14 PM
  3. Piston slap or not???
    By casperss in forum Internal Engine
    Replies: 6
    Last Post: 09-21-2007, 08:06 PM
  4. piston slap?
    By wicked illusions in forum Camaro / SS
    Replies: 4
    Last Post: 05-28-2006, 06:27 PM
  5. Piston Slap
    By CamaroSSx1999 in forum Internal Engine
    Replies: 6
    Last Post: 08-29-2005, 02:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •