Results 1 to 6 of 6

gauge light

This is a discussion on gauge light within the General Help forums, part of the LSx Technical Help Section category; i don't drive a trans am...my friend sent me a picture ..he asked me what it was that appeared on ...

  1. #1
    Senior Member 35thAnniZ28's Avatar
    Join Date
    Mar 2007
    Location
    Texas
    Posts
    1,809

    eating bulldog
    son of biscuit

    gauge light

    i don't drive a trans am...my friend sent me a picture ..he asked me what it was that appeared on his gauges any help and how to take it off?[IMG][/IMG]

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    I think that is the low coolant light but I am not 100% certain.

  3. #3
    Senior Member M-Ten's Avatar
    Join Date
    Jun 2007
    Location
    St. Pete, Florida
    Age
    27
    Posts
    2,210

    Silver+Black/Black+Silver
    1999 TA M6/03 GSXR 600

    yep it's the low coolant light, how to fix it? put more coolant in

  4. #4
    Senior Member Tyler_LS1's Avatar
    Join Date
    Sep 2006
    Location
    Canby, Oregon
    Age
    29
    Posts
    2,121

    Pewter
    1999 Camaro SS-M6 #1775

    Its the Low Coolant light...

    put more coolant in, if that doesnt help then the sensor might be corroded.
    1999 Camaro SS/ Pewter/ #1775 - LS1 6-speed - Predator 3 Custom Tune - Pro 5.0 - LS7 Clutch - 3.90's - Koni's - Strano Springs and Sway Bars - SFC's - Full UMI Chassis and Suspension - LS6 Intake PnP TB - ARH LT's and Kitty Ran Away - Magnaflow.

    12.6 at 112

    http://www.fquick.com/Tyler_LS1

  5. #5
    Member theGeneral's Avatar
    Join Date
    Jul 2007
    Location
    DFW
    Age
    35
    Posts
    185

    Ignition Orange Metallic
    '08 G8 GT

    If it is the sensor he can either 1) unplug it and just check the levels periodically or 2) buy a new one which is around $50.

  6. #6
    Senior Member M-Ten's Avatar
    Join Date
    Jun 2007
    Location
    St. Pete, Florida
    Age
    27
    Posts
    2,210

    Silver+Black/Black+Silver
    1999 TA M6/03 GSXR 600

    mine goes on and off at random times, the first thing i did was replace the sensor, cost like $20, but didn't even fix it.. so I just kinda gave up lol.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Check Gauge Light
    By Mookz1 in forum General Help
    Replies: 8
    Last Post: 07-05-2012, 04:28 PM
  2. Gauge pod with shift light help!
    By ls1_bandit in forum Firebird / WS6
    Replies: 2
    Last Post: 01-06-2011, 03:09 PM
  3. Help Gauge doesn't light up
    By Speed Psychosis in forum General Help
    Replies: 2
    Last Post: 02-06-2008, 01:00 PM
  4. Gauge light off and on
    By GreenBirdman in forum Stereo and Electronics
    Replies: 1
    Last Post: 04-20-2007, 10:42 AM
  5. Check Gauge Light
    By Terrance in forum General Help
    Replies: 7
    Last Post: 03-18-2006, 06:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •