Results 1 to 8 of 8

Gas Gauge not working

This is a discussion on Gas Gauge not working within the General Help forums, part of the LSx Technical Help Section category; so my gas gauge isnt working when i refill it goes to empty then as the tank seem to get ...

  1. #1
    rsg98Z28 rsg98Z28's Avatar
    Join Date
    Dec 2007
    Location
    Atlanta, GA
    Posts
    90

    Black
    1998 Camaro Z28 vert

    Gas Gauge not working

    so my gas gauge isnt working when i refill it goes to empty then as the tank seem to get used up it will read full. sometimes when im driving it willstart on empty and after around 15 min. it will gradually got to full. any sugestion would be great thanks.

  2. #2
    Junior Member dougsandy127@comcast's Avatar
    Join Date
    Nov 2007
    Location
    Vancouver, WA
    Posts
    7

    Red
    2001 & 2004 Corvette

    Quote Originally Posted by rsg98Z28 View Post
    so my gas gauge isnt working when i refill it goes to empty then as the tank seem to get used up it will read full. sometimes when im driving it willstart on empty and after around 15 min. it will gradually got to full. any sugestion would be great thanks.
    Pour a bottle of Techron in it and run a tank through. You may have to do this a couple times and it will clean up the sensors and the tank will read correctly. Common problem on C5s and imagine GM uses similar sensors on the F bodies.

  3. #3
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    sounds like something is coming apart in the swing arm inside the tank...
    or te contacts are severely worn... how many miles are on it???

  4. #4
    rsg98Z28 rsg98Z28's Avatar
    Join Date
    Dec 2007
    Location
    Atlanta, GA
    Posts
    90

    Black
    1998 Camaro Z28 vert

    the techron thing seems to make sense but it seems to easy, my car has 130,000 miles on it so mybe its just worn

  5. #5
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    could be time to replace it... but sit down. O'Rielly's wants $188.00 for the "unit", which includes the gauge sending unit and the pump all together... no one i have found sells just the sending unit...

  6. #6
    Senior Member Shermanator86's Avatar
    Join Date
    Sep 2007
    Location
    LaGrange, Indiana
    Posts
    1,238

    Pewter
    2001 Camaro SS hard top

    my gas gauge doesn't work, i've been told its a common issue with our cars. mine will read somtimes if a hit a bump in the road hard or something but 95% of the time it just doesn't work, what causes this?

  7. #7
    Junior Member dougsandy127@comcast's Avatar
    Join Date
    Nov 2007
    Location
    Vancouver, WA
    Posts
    7

    Red
    2001 & 2004 Corvette

    Quote Originally Posted by rsg98Z28 View Post
    the techron thing seems to make sense but it seems to easy, my car has 130,000 miles on it so mybe its just worn
    It could be worn, but at the price and hassel of replacing the sending unit giving the techron a try can't hurt. My Z was doing exactly the same thing at 65K until I started feeding it a semi regular diet of techron. You can always spend the big bucks later.

  8. #8
    Member Pete Rock98's Avatar
    Join Date
    Aug 2005
    Location
    Bronx NY
    Age
    47
    Posts
    177

    Black
    1998 z28

    It's the fuel sender

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Temperature gauge not working
    By LgndKller20073 in forum General Help
    Replies: 9
    Last Post: 12-27-2011, 03:47 AM
  2. Temperature gauge not working.Help!
    By J'stransam in forum General Help
    Replies: 5
    Last Post: 04-14-2010, 08:20 AM
  3. Engine temp gauge not working
    By drummer52910 in forum General Help
    Replies: 3
    Last Post: 06-09-2008, 09:13 AM
  4. wtf? gas gauge stopped working
    By third_shift|studios in forum General Help
    Replies: 13
    Last Post: 12-22-2007, 07:48 PM
  5. gas gauge is not working properly
    By zach_ws6 in forum General Help
    Replies: 1
    Last Post: 10-23-2005, 05:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •