Results 1 to 7 of 7

Fuel Pump questions

This is a discussion on Fuel Pump questions within the General Help forums, part of the LSx Technical Help Section category; Ok...so had a great time taking it for it's first cruise. Less than 1/4 mile from the house it dies. ...

  1. #1
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Fuel Pump questions

    Ok...so had a great time taking it for it's first cruise. Less than 1/4 mile from the house it dies.

    Almost zero pressure at the rails. So I change out a new filter just in case. No change. So today I chase down every connector to see is it has pwr. I even pulled the pump to make sure and it's getting it. Also saw that the sock fell off. Not sure if it came off while I was pulling the pump or it fell off.

    Now while turning it over i had the pump in hand a felt it click and make a little noise. I looked in the pick up side and see what looks like gears. They do not seem to be moving.

    So dead pump or just clogged?
    http://www.ls1.com/forums/f7/my-6-liter-build-174257/

    http://www.ls1.com/forums/f8/my-8-8-rear-build-165553/

    6.0L Block - Forged 403 built, breaking it in , Polluter Stg3 Cam, FAST 102mm Intake, NW102 TB, MSD wires, NGK TR6 plugs, Truck Coil Packs, LS3 Fuel Injectors, CC Pacesetter LT Headers, TS&P ORY, QTP e-Cutout, Magnaflow Muffler, 104mm Air Lid & Line Lock, Catch Can, Stage 2 T56 w/Viper shaft, PRO 5.0 Shifter, Tick MC, Monster Stg 4 Clutch, QT SFI BH, MWC DSL, UMI: SFC, PHB, LCA's, LCA Relocation Brackets & TA, Hotchkis Springs (1" Drop), YR1 Snowflake Wheels wrapped in NT555 tires & Custom Fab Ford 8.8 rear w/4.10 Yukon Gears, WSQ Hood, 3"CM Strange Eng Drive Shaft.

    Horsepower never lies, but is often lied about!

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Sounds dead. You have power to the pump and it's not working. Did you have any debris in your tank when you installed the new pump? Try tapping on the pump a bit to see if it'll kick on... but at this point I don't know if I would trust it.

  3. #3
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Fuel Pump questions

    no debris. I clean it all before I installed the 1st time.

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Fuel Pump questions

    is there a warranty on racetronix pumps?

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Should be. You buy it directly from their site?

    By chance, was the fuel pump relay in the Racetronix harness an RL44 (4 prong, 40 amp)?

  6. #6
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    No, it has a different style relay. The prongs are different in set up.

    I'll post a pic later.

    Well I talked to WS6store and I'm too far out of the warranty they offer. I'm waiting on their tech support to call me to go over troubleshooting to make sure it is defiantly the pump.

  7. #7
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Ok - hope they come through for you.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel pump fuel guage issues on my '02 B4C
    By ANDYZ28 in forum Camaro / SS
    Replies: 7
    Last Post: 12-29-2014, 11:30 AM
  2. LS1 all yr fuel injectors, oe fuel rail, pump,more
    By Frost in forum Parts For Sale / Trade
    Replies: 7
    Last Post: 04-27-2009, 03:26 PM
  3. Fuel Pump Questions
    By AF1Strider in forum Camaro / SS
    Replies: 8
    Last Post: 08-01-2008, 04:41 PM
  4. Replies: 3
    Last Post: 10-02-2006, 07:23 PM
  5. Fuel pump Questions
    By Qwk94Z28 in forum General Help
    Replies: 2
    Last Post: 02-23-2006, 11:01 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •