Results 1 to 2 of 2

Fuel pump problem

This is a discussion on Fuel pump problem within the General Help forums, part of the LSx Technical Help Section category; This is for a third gen camaro but should apply for the 4th gens as well, I recently installed a ...

  1. #1
    Hemi Destroyer 98-LS1's Avatar
    Join Date
    Oct 2005
    Location
    Knoxvegas, Vol country Tennessee
    Posts
    1,112

    Sebring Silver
    98 Z-28 camaro

    Fuel pump problem

    This is for a third gen camaro but should apply for the 4th gens as well, I recently installed a Walbro fuel pump for my LS1 conversion. Well tonight I plugged the ignition harness to the battery to test the pump and the clutch wiring, the pump wouldn't do anything. The car was a factory LG4 4bll 305 car but had both an electric in-tank pump and mechanical pump on the engine block. I hooked the new pump up just like it came out but it's not doing anything. I looked at the fuse panel to see if a fuse was blown but there isn't a fuse for the fuel pump. Where does this thing get power? If I could find the source then I could throw a multimeter to it and figure something out. Also, there is no gas in the tank but it should still come on. Is that pump ran by the computer? If it is then that's the problem because I removed the computer and ECM harness to install the LS1 painless harness. Thanks,

    98-LS1

  2. #2
    Member LS1Z28's Avatar
    Join Date
    Aug 2005
    Location
    Lake Elsinore,CA
    Posts
    280
    Camaro

    The intank pump was a recall add on. It uses a seperate harness and has a dedicated fuse that should be mounted under the hood on the passenger side of the firewall.It has it's own plastic holder with two wires coming out of it. We did a lot of these recalls on cars with vapor lock.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fuel pump fuel guage issues on my '02 B4C
    By ANDYZ28 in forum Camaro / SS
    Replies: 7
    Last Post: 12-29-2014, 10:30 AM
  2. Pontiac Fuel Pumps - Do You Have The Right Fuel Pump?
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 03-15-2011, 09:20 PM
  3. Walbro 255 GSS341 intank fuel Pump problem
    By John Junkins in forum General Help
    Replies: 5
    Last Post: 02-18-2008, 01:44 AM
  4. Fuel Pump Problem!!
    By M-Ten in forum General Help
    Replies: 24
    Last Post: 12-04-2007, 08:38 AM
  5. Fuel Pump Pump Problem?????? Help!
    By undertakersT/A in forum General Help
    Replies: 4
    Last Post: 04-24-2006, 09:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •