Results 1 to 3 of 3

fuel & Idle after cam install

This is a discussion on fuel & Idle after cam install within the General Help forums, part of the LSx Technical Help Section category; I just picked my hawk up today from a local speed shop after having a new cam, lifters,etc installed. When ...

  1. #1
    Member
    Join Date
    Mar 2007
    Location
    St Louis, MO
    Posts
    155

    Pewter
    99 Firehawk convertable

    fuel & Idle after cam install

    I just picked my hawk up today from a local speed shop after having a new cam, lifters,etc installed. When I first started it up really didn't want to Idle to well, but after a few minutes it Idled real good. But now it is running way to rich.Next sat I'm going to have it tuned. I hope that this will correct the Idle & the fuel. The cam is a comp 222/224 566/568 lift 112 lobe separation. Am I correct or not, any other suggestions with the tune thankscam insta

  2. #2
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    get a tune and that should fix you right up.

  3. #3
    Member fxgs's Avatar
    Join Date
    Mar 2007
    Location
    Camp Hill, Pa
    Posts
    719

    Onyx Black
    2002 SLP Camaro SS

    I'm running a Comp Cams 223 227 .637 .640 110 LSA...................
    very choppy, hard to idle until warm, etc., etc.
    Got my tune and it took care of all of that..............

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 99 TA has low idle after cumpter install.
    By Street Fighter in forum Computer & Tuning
    Replies: 4
    Last Post: 06-19-2015, 11:12 AM
  2. new cam install no idle
    By seweber in forum Internal Engine
    Replies: 12
    Last Post: 03-17-2012, 08:34 AM
  3. High Idle after APS and 317 heads install
    By fil131 in forum Internal Engine
    Replies: 9
    Last Post: 07-01-2008, 10:03 PM
  4. Low Idle After Header Install.
    By DeadLifter in forum General Help
    Replies: 2
    Last Post: 01-09-2008, 02:35 PM
  5. Rough idle / fuel smell on 98 LS1
    By slaude in forum External Engine
    Replies: 7
    Last Post: 11-16-2006, 06:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •