Results 1 to 2 of 2

FTRA problem

This is a discussion on FTRA problem within the General Help forums, part of the LSx Technical Help Section category; I'm just now getting around to installing my ftra, but I think they may have sent me the wrong air ...

  1. #1
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    FTRA problem

    I'm just now getting around to installing my ftra, but I think they may have sent me the wrong air plate. In the picture it shows the plate is a good 2 inches wider than the duct on both sides...my plate is 1/8 inch smaller than the duct on both sides. It doesn't assemble at all like the photo shows...on the plate they sent me the sides are bent down about 1 1/2 inches, like it's supposed to wrap around the duct. Shit doesn't fit at all...anyone have a similar experiance?


    Last edited by SeVeReDiStOrTiOn; 11-12-2005 at 12:23 PM.

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    I've had one on my car for about 3 years now - just went out and looked at it from the bottom and the "ram air plate" and "cold air duct" are the same width - not like that pic. The lower portion with the bent sides should slide up inside the upper part of the duct. I think it's an early model pic that needs to be updated in their insts. Let me know if you want me to take some measurements of mine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem after Problem
    By boone94 in forum Internal Engine
    Replies: 9
    Last Post: 11-04-2005, 06:31 PM
  2. SERIOUS Tranny Problem! HELP!!!
    By GTObsessor in forum Manual Transmission
    Replies: 7
    Last Post: 10-25-2005, 06:19 PM
  3. On going problem
    By wc00ac in forum LT1
    Replies: 2
    Last Post: 09-25-2005, 09:44 AM
  4. Torque Arm Mount problem
    By FlewbyurGT in forum Manual Transmission
    Replies: 0
    Last Post: 09-23-2005, 02:34 AM
  5. alarm problem
    By jagyro in forum Stereo and Electronics
    Replies: 0
    Last Post: 09-19-2005, 12:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •