Results 1 to 7 of 7

Front turn signal wont work?

This is a discussion on Front turn signal wont work? within the General Help forums, part of the LSx Technical Help Section category; So i went and tried to replace the bulbs because the turn signal wouldnt work to turn left. It just ...

  1. #1
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    Front turn signal wont work?

    So i went and tried to replace the bulbs because the turn signal wouldnt work to turn left. It just hangs, my Camaro did that when it was time to replace the bulb. Since the turn signal is also the day time running light on the Trans am i had to get a certain bulb. When i put it in the running light works but the blinker signal still doesnt work, i even tried trading the bulb from the other side. Someone told me the wiring in the pig tail might have gone bad, i was just curious as to what you guys thought the fix might be. Its a 1999 Trans Am.

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Was there any rust or corrosion on the socket?
    Also check the rear bulb as well.
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    The rear bulbs are still good, i didnt notice anything in the socket but the other builb in the passengers side feels like it seats???? All the way where as the bulb in the drivers side doesnt feel like it does. I think a piece might be missing or there might be something preventing something from connecting? The right bulbs in there and the running light works just fine. The back lights light up for the turn signal but dont blink and the front one doesnt blink at all but just turns out.

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    the socket is either A) corroded or B) burnt/worn out. I am having the same issue. What I do, untill I can replace the socket, is give the bulb a wiggle with the turn signal activated to get it to make contact.

  5. #5
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    like sunset said...check that socket. Common to corrode and easy to replace.

  6. #6
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    69
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    New sockets are available at AutoZone #81885.....less than $10 each.
    Solder them in & use two coverings of heatshrink tubing, pack with dielectric grease, put some LED's in & never look back

  7. #7
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    Thanks guys Ill pick up the part this week and see if thats it, if its not illllll be back.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Front Turn Signal/Running lamps don't work
    By scStormChaser in forum General Help
    Replies: 11
    Last Post: 04-12-2015, 06:54 PM
  2. Help: ws6 front turn signal screws
    By james3340 in forum Firebird / WS6
    Replies: 1
    Last Post: 06-09-2013, 11:11 AM
  3. HELP! right turn signal doesnt work! (2000 WS.6)
    By ScottWernWS6 in forum General Help
    Replies: 4
    Last Post: 12-01-2010, 07:07 AM
  4. Help: Front Turn Signal
    By davidz28 in forum Camaro / SS
    Replies: 12
    Last Post: 01-02-2010, 04:21 PM
  5. WTB: Front Turn Signal Pigtails for 98-02
    By FormulaFiend in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 10-19-2006, 06:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •